Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    OYESNOS's Avatar
    Join Date
    Jun 2011
    Location
    Stedman,North Carolina
    Posts
    29

    RXT-X code P1116

    Have all the Riva Stage II component and then some. Still have closed loop cooling system and stock ride plate. Was riding this weekend, 95 F and 89 degree water temp. Made about 4 wide open runs at 8520 rpm to get gps speed, then set the code. Question is do I have to run an open loop cooling system with these other mods to keep temp. down.


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Check for a blown headgasket. I am guessing you are running a RIVA ecu? Any coolant in the hull at all? What SCer are you running? Do you know what your AFRs are? "StageII and then some" isn't much info.

  3. #3
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Still using the OEM T-stat?

  4. #4
    OYESNOS's Avatar
    Join Date
    Jun 2011
    Location
    Stedman,North Carolina
    Posts
    29
    Yes,there is some coolant in hull. Will do compression test tonight. Riva thermostat kit, Riva ECU, 50lb inj.,valve train upgrade, Riva regulator kit with 60 psi static fuel pressure(not rising rate)Have Innovate wide band. Have Riva original upgraded X-charger housing and impeller. 11.5-12.0 psi @ 8500 rpm. AFR is 11.8 @ WOT. This should'nt be to far out of range should it ?

  5. #5
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by OYESNOS View Post
    Yes,there is some coolant in hull. Will do compression test tonight. Riva thermostat kit, Riva ECU, 50lb inj.,valve train upgrade, Riva regulator kit with 60 psi static fuel pressure(not rising rate)Have Innovate wide band. Have Riva original upgraded X-charger housing and impeller. 11.5-12.0 psi @ 8500 rpm. AFR is 11.8 @ WOT. This should'nt be to far out of range should it ?
    You are good on the AFs. Usually a compression or leakdown test will not reveal a blown headgasket. The only time you will lose coolant is when you are in the boost and sometimes just at WOT.

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Long shot, but any chance you had all the hoses off the thermostat housing. Sometimes the oil cooler hose get mixed up with the hose next to it. You still more than likely have blown headgasket, tho.

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by OYESNOS View Post
    Yes,there is some coolant in hull. Will do compression test tonight. Riva thermostat kit, Riva ECU, 50lb inj.,valve train upgrade, Riva regulator kit with 60 psi static fuel pressure(not rising rate)Have Innovate wide band. Have Riva original upgraded X-charger housing and impeller. 11.5-12.0 psi @ 8500 rpm. AFR is 11.8 @ WOT. This should'nt be to far out of range should it ?
    Agree with JP, afr's are good, but is that all the boost you are seing now, or did you see more before the coolant leak? I ask because at 8500 I have been seeing 14.5 lbs of boost with the same charger.

  8. #8
    OYESNOS's Avatar
    Join Date
    Jun 2011
    Location
    Stedman,North Carolina
    Posts
    29
    Have not had hoses of in a while, but thanks for the info.

  9. #9
    OYESNOS's Avatar
    Join Date
    Jun 2011
    Location
    Stedman,North Carolina
    Posts
    29
    This is not the new Riva XX upgrade. This the original upgrade that was on clearance and is now discontinued.

  10. #10
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by OYESNOS View Post
    This is not the new Riva XX upgrade. This the original upgrade that was on clearance and is now discontinued.
    Yes. I have the old Riva X charger upgrade that they do not sell anymore.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 seafood rxt x 255 fault code p1116
    By Fatboy1399 in forum Flyboard
    Replies: 2
    Last Post: 08-02-2015, 07:33 PM
  2. 2005 rxt fault codes
    By hognut2000 in forum 4-Tec Performance
    Replies: 21
    Last Post: 04-19-2012, 05:31 PM
  3. RXT Maint code
    By Rford09 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-08-2010, 01:38 PM
  4. 08 x ecu on a 07 rxt? Getting code p1513
    By 556SBR in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-25-2009, 06:18 AM
  5. Error ENGINE code P1116
    By sr71bb in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-15-2006, 09:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •