Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87

    Riva FZR intake question??????

    I cant get the intake tube to slip over the SC adapter....... Is it even supposed to??


  2. #2
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    Install the black piece first (its directional) and then the white screw on adapter. Put the blue silicone coupler on the powerfilter and then insert onto the SC. Hope that helps!
    Also, install the screw into the lord mount before you tighten the clamps on the coupler.

    instructions: http://www.rivaracing.com/instructions/ry13040.pdf

  3. #3
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by mikeFZR View Post
    Install the black piece first (its directional) and then the white screw on adapter. Put on the blue silicone coupler and then insert the powerfilter. Hope that helps!
    Tried that. This is the problem I have.

    Will NOT slide into the tube.

  4. #4
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    That looks like a picture of the top SC opening to the IC, but I'm probably mistaken. Can you describe your problem a bit more?

  5. #5
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Bes other pic I have.

  6. #6
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    JT that's exactly how it should look. You just need the silicone coupler to connect the two

  7. #7
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by mikeFZR View Post
    JT that's exactly how it should look. You just need the silicone coupler to connect the two
    But isnt that white SC adapter supposed to slip into that intake tube??

  8. #8
    leave both hose clamps loose and use Windex. Silicone coupler should cover white piece all the way to back edge.

  9. #9
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    Quote Originally Posted by jtskier11 View Post
    But isnt that white SC adapter supposed to slip into that intake tube??
    I'm not at my ski but I'm almost certain it does not. It's only attached by the coupler.

  10. #10
    Kelly_A's Avatar
    Join Date
    Dec 2009
    Location
    Central Oklahoma
    Posts
    660
    +1
    17
    Mike is correct, they butt together, but only the coupler joins the two. That leaves just a bit of flex in the connection to allow for motor movement and to damp vibration.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone have a riva fzr intake??
    By Jmfmk3 in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 06-15-2013, 10:48 AM
  2. riva air intake question
    By rearviewneons in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-29-2011, 05:13 PM
  3. Riva air intake question.
    By sylvan in forum 4-Tec Performance
    Replies: 8
    Last Post: 10-04-2009, 02:06 AM
  4. 3" Riva air intake question
    By Mccoy in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-28-2008, 11:24 AM
  5. Riva rear intake question
    By suck my wake in forum 4-Tec Performance
    Replies: 10
    Last Post: 09-19-2007, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •