Results 1 to 10 of 10
  1. #1

    Coolant leak = need help!!!

    07 rxp so im cruising,engine codes out overheating, i tow it back, fill it with coolant and the coolant runs out somewhere where i cant see, its going in to bottom, drain it through the plug, try it again same thing so i know its going in the boat, take to the dealer, they tell me the ride plate is jacked up, 800 dollar repair,thats not putting on a ride plate but fixing some ride plate plugs,,,,,,,,,,,,,,,ok so if it was the ride plate wouldnt it drain out the bottom of the boat????? just seems very odd to me, said they talked to some engineer at seadoo on this fix without buying a rideplate


  2. #2
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Sounds like your HG to me. Check to see where it's leaking from. If it's coming out the overflow on the coolant bottle, your head gasket is cactus..

  3. #3
    no not at all, its cold, i fill the bottle , runs out the bottom somewhere where i cant see, so im wondering to the plugs on the rideplate have something to do with it cause thats what the dealer wants to fix, and the fix they want to do they said is cheaper than buying a rideplate, jst seems odd to me

  4. #4
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    With them wanting to replace the rideplate, I would check the inlet and outlet fittings to the rideplate. Could be just one of the fittings or even a hose, really need more info.

    A rideplate costs about $260.00 and the fittings are pretty cheap,

    http://partsfinder.onlinemicrofiche....=13&A=149&B=14

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Does it only leak when u run wide open or can you idle around and it leaks out?

  6. #6
    Quote Originally Posted by Ocman View Post
    Does it only leak when u run wide open or can you idle around and it leaks out?
    runs right out from the get go, not even starting it, soon as fill the bottle its running in the bottom, i needen more info also but they kept saying either do this fix they suggested from seadoo engineer or get another rideplate,,,,,,,,oh and the 800 included changing the wear ring

  7. #7
    well stick a hot poker in my eye!!!!!!!!!!ahhhhhhh i think i know what happened after reading some threads on it, at the end of last year i got a huge stick get stuck, for the life of me couldnt get it out, trying to pull the ride plate off i didnt remove the hoses and bet i cracked the hose fittings cause i was cranking the shit out of that plate to get it off but never did,,,,,,,,,,but damnit i got that stick out

  8. #8
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    Sort of sounds like one of the fittings or clamp is broken on the ride plate. If you are still using the stock spring type hose clamps on the ride plate there have been several here have problems with them leaking.

  9. #9
    Quote Originally Posted by DaveC View Post
    Sort of sounds like one of the fittings or clamp is broken on the ride plate. If you are still using the stock spring type hose clamps on the ride plate there have been several here have problems with them leaking.
    so are they attached to the ride plate or seperate components that you can buy, or do you really need to buy a new rideplate

  10. #10
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    You can buy the plastic pieces that screw onto the ride plate, number 14 in the micro fiche link I posted above. If it is the internal fitting in the ride plate that part number has been listed GH before but does not appear on the micro fiche(not sure if they are still available or not). If you can remove enough parts to find the leak you will find plenty of help here on fixing it. You could luck out and it be a hose clamp or hose, perhaps a fitting. Worst case may have to replace the ride plate, not a difficult job but it is somewhat time consuming.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 rxp water leak need help
    By jcturbo in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-23-2016, 08:45 AM
  2. NEED HELP: 2007 GTI se155 coolant leak and water leak
    By bamafutbal in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-09-2014, 02:19 PM
  3. Gp1200 oil leak NEED HELP
    By Brentduncan29 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-16-2013, 06:55 AM
  4. 2005 speedster oil leak need help
    By Tarek in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-18-2013, 04:32 PM
  5. Replies: 2
    Last Post: 03-26-2011, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •