Results 1 to 2 of 2
  1. #1

    Join Date
    Jun 2011
    Location
    new jersey
    Posts
    4

    97 xp carb issues

    i have a 97 xp 787. i put a new engine in it a couple months ago. i put it in the water for the break in and it would load up and bog down at high rpm i brought it home and ran it to flush it out then pulled the plugs were soaked. the settings on the speed screws were off so i rebuilt the carbs and adjusted everything to factory specs. it runs a little better but still seems like its getting to much fuel at high rpm. any suggestions are appreciated

    also im doing the adjustments while its running on the hose. is it possible im hitting the rev limiter since there isnt any load on it


  2. #2

    Join Date
    Jun 2011
    Location
    new jersey
    Posts
    4
    figured it out. it was sucking fuel through the accelerator pump

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 GTX carb issue?
    By EricP in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-03-2010, 11:59 PM
  2. 97 XP Starting issue
    By Slow 91 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-20-2010, 10:52 AM
  3. Need some help... 97 XP.. starting issues...
    By midnight08 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 05-29-2009, 12:19 PM
  4. Looking at a '97 xp...any issues?
    By Fish Man in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-16-2008, 09:03 PM
  5. 97 XP Starting issue
    By djdeet in forum 2-Stroke Performance
    Replies: 13
    Last Post: 08-09-2007, 11:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •