Results 1 to 8 of 8

Thread: Pump inspection

  1. #1

    Join Date
    Mar 2008
    Location
    Harrisonville Missouri
    Posts
    239

    Pump inspection

    Alright, I started a thread last weekend about the first trip out with the RXP. It abruptly started running rough like maybe something in the impeller or pump. I could not see anything in the impeller so I finally got it at the house yesterday and yanked the venturi off.
    My question is shouldn't I be able to see everything I need to see with out actually removing the pump? If so it is time to replace the plugs and put fresh gas in it which I picked up today.
    If there is something else I need to check what is it?
    thanks
    Joe


  2. #2
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4
    If you are running stock impeller make sure the nose cone did not walk up the shaft.

  3. #3

    Join Date
    Mar 2008
    Location
    Harrisonville Missouri
    Posts
    239
    How so??? Do I need to go ahead and pull the pump???

  4. #4

    Join Date
    Mar 2008
    Location
    Harrisonville Missouri
    Posts
    239
    Well new plugs new gas. Hooked the hose on it and it sounds much much better. Thankfully I think it was just a bad plug. SWEEEEEEET!!!!!!!!!! Might have to look into Fizzles intercooler.
    thanks all for the advice.

    OUT

  5. #5
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Quote Originally Posted by GYTWYPT View Post
    How so??? Do I need to go ahead and pull the pump???
    I would! Just to get some assurance. There could be an underlying issue.

  6. #6
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    Quote Originally Posted by GYTWYPT View Post
    How so??? Do I need to go ahead and pull the pump???
    Pull it, it's not that hard like a 5 min job. once you find all the sockets Seriously though..

  7. #7

    Join Date
    Mar 2008
    Location
    Harrisonville Missouri
    Posts
    239
    Oh I know its not that hard but what else am I looking at??????

  8. #8
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Looking at the nose cone that is/was on the impeller. See if it has come loose and walked up the drive shaft. If it is still attached to the impeller, it didn't walk up the shaft. Chances are the prop might be loose.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra-300x Jet Pump Inspection/Maintenance
    By Spooling in forum Kawasaki PWC Performance (4-stroke)
    Replies: 90
    Last Post: 10-23-2013, 04:32 PM
  2. 2012 RXP-X jet pump inspection
    By pro1200 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-19-2012, 08:06 AM
  3. 300x jet pump inspection (need help)
    By ange5583 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 02-21-2012, 07:07 PM
  4. Pump inspection 98 Waverunner 1200XL
    By whazzup in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-11-2009, 07:10 AM
  5. Pump inspection tips
    By littlej72 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-13-2007, 03:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •