Results 1 to 2 of 2

Thread: 97 gsx mpem

  1. #1

    97 gsx mpem

    Pretty sure my MPEM is dead, at first you had to pull the lanyard on and off and every now and then the dash would light up. now it won't work at all. have tried new lanyard, magnet, new post and buds but nothing works, no blown fuses either. if anyone has any useful threads they know of for helping me diagnose the problem let me know. other wise pm me a price for an MPEM. Thanks in advance.

    Nathan


  2. #2
    Check all your grounds and the 6-Pin Connector (both sides) which plugs into the
    front of the Engine on the MAG. Cover for corrosion.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 GSX won't start
    By WBFD19 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 04-29-2008, 10:22 AM
  2. 97 GSX won't start
    By WBFD19 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-28-2007, 08:16 PM
  3. Help with 97 GSX questions
    By Mac Daddy Racing in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-23-2007, 10:15 AM
  4. 97 GSX Cavitation?
    By BigT in forum 2-Stroke Performance
    Replies: 24
    Last Post: 11-22-2006, 09:16 PM
  5. 97 gsx Question
    By ou812 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 11-17-2006, 07:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •