Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2001 Genesis i - EMM computer mounting

    Took apart need info on how to reinstall - picture preferred; mount instruction steps


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    2001 Polaris genesis i

    Does this parts diagram help?



    EMM mounts to the bracket face, capacitor mounts on top. The whole thing sits on top of the battery.

    Do you have all the mounting hardware?

  3. #3
    thank you so much i hope i can find the mounting hardware

  4. #4
    one more question...once i have everything hooked up do i need to do anything else before cranking for the
    1st time?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Oil lines primed and bled of air bubbles?

    You cannot add oil to the fuel on an injected engine so it is important that the oil lines be primed as much as possible. Dribble some 2-stroke oil down the air intakes before engine start to give it some extra lubrication.

    Fresh fuel in the tank?

    Strong battery?

    Limit run times to under 20 seconds out of the water if running without water cooling.

    2 minutes maximum if running on the garden hose.

    Garden hose sequence;
    Start engine, THEN start water
    Stop water, burp throttle to clear water box, THEN stop engine.

    With no load on the engine, all you can do is confirm that all three cylinders are getting equally warm, and that no problems are indicated.

  6. #6
    great..thanks but how do i bleed the oil lines?

  7. #7
    also.. there are 2 brass fittings on the fly wheel cover. the top one is the oil line, and the bottom one is for water. is this correct?

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by malteseowner View Post
    ... there are 2 brass fittings on the fly wheel cover. the top one is the oil line, and the bottom one is for water.

    is this correct?
    No.

    All the oil lines connect to the oil pump itself. The oil pump is mounted in the center of the flywheel cover, and is surrounded by the horseshoe shaped water jacket cover.

    One small cooling hose connects to the water jacket cover down low, below the oil pump. The other water hose elbow is up somewhere above/near the oil pump (if memory serves).

    You can use a small mirror to help see what is what down there.

  9. #9
    gottcha.. i've got the oil line connected to the oil pump and the lower cooling line fitting (on the bottom of the flywheel cover) goes to a cooling line that also connects to the exhaust manifold. and what a buger it was getting that hose on AFTER i installed the manifold. and the upper cooling hose goes to the Computer. i just wanted to take the time to thank you for taking the time to help everyone who you answer. you must be VERY busy
    Lisa
    oh... still need to bleed oil lines (how?)

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by malteseowner View Post
    ... need to bleed oil lines (how?)
    There is a bleed screw on the oil pump that will allow the air out of the feed hose from the oil tank. Have a rag on hand as oil will seep out while the screw is loosened.

    For the oil lines to the engine you can use a syringe or small funnel to fill each hose with oil, then reconnect. A bit messy, so put rags down first.

    You don't need to get ALL the air out of the hoses, just most of it.

    Dribble some oil down each air intake before starting the motor, just so you know it has oil in there. It will smoke until the excess oil is burned off.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris genesis ground/emm issue?? please help
    By CJW2016 in forum Polaris Open Discussion
    Replies: 66
    Last Post: 06-10-2016, 05:00 PM
  2. 2001 Genesis no-spark, no-fuel
    By chev-hell in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-24-2007, 04:50 PM
  3. Thinking of buying this 2001 Genesis - Opinions or comments?
    By K447 in forum Polaris Open Discussion
    Replies: 15
    Last Post: 09-12-2007, 05:16 PM
  4. 2001 Genesis cutting out
    By go2lkg in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-21-2007, 06:11 PM
  5. friends 2001 genesis
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-13-2007, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •