Results 1 to 7 of 7
  1. #1

    Thumbs down 02 Honda f 12x partial submersion in salt water today.

    yes, I actually did that. I forgot the plugs. Can anyone shine some light on the proper proceedure for this? The engine ingested a small amount of water while running at idle. It did not hydrolock, but doesnt really run. it tries, but I truely dont want to cause further damage.


  2. #2
    I guess the water came about half way up the crankcase. I dont want to leave it in this condition for any length of time and everyone around here is closed now. Im pretty mechanicly inclined, but Ive never done much with a turbo four stroke. Any help???

  3. #3

    pull plugs

    pull plugs, spray little wd40 in the cylander, and fire away on the start button. Have to get the water out. spray everything down w WD after. Once water stops coming out of cylanders, put plugs back in and fire it up and let run on the hose for 30mins at least. I had a exhaust hose come loose last week and half sunk my ski. Have to it running tonight with the water out of it or its as good as gone! good luck! This is the best thing I know how to do.

  4. #4
    the cylinders dont appear to have water in them. it actually fires and runs, but very rough. it chugs a bit and doesnt want to idle. do you think it just needs to be run more? or should i pull the plugs anyway? Thanks for the help.

  5. #5
    Im now pretty sure that it has at least one plug fowled. this may be the entire problem now. please correct me if you think I am wrong.

  6. #6
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    895
    +1
    225
    Take out your oil dip stick and have a look at it is the oil black or milky no good.

    If milky clean out all the old oil and filter and flush out untill not milky antmore and then run it get warm and if any more water to come out and check and change oil again if needed.

    Regards Xdrian

  7. #7
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    Quote Originally Posted by simplemanft View Post
    yes, I actually did that. I forgot the plugs. Can anyone shine some light on the proper proceedure for this? The engine ingested a small amount of water while running at idle. It did not hydrolock, but doesnt really run. it tries, but I truely dont want to cause further damage.
    Pull loose the tube off the discharge to the turbo and use a lawnblower to blow air through the induction system while you spin the engine over with the plugs out. Suck all of the oil out and replace it. Run the ski and check the oil for the milky appearence from water. If it is Ok then ride it for several hours. Do not let it sit and rust or you'll be sorry.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 Honda f-12x realistic top speed???
    By RXPblackandgold in forum Honda Performance
    Replies: 6
    Last Post: 04-01-2012, 07:52 AM
  2. FS 02 Honda F-12X with MB Stage 2 $4000 with Trailer
    By Redcrownline in forum Honda Skis
    Replies: 2
    Last Post: 01-21-2010, 11:44 AM
  3. I need wastegate for 02 Honda F-12X
    By cuban133054 in forum Honda How To & FAQs
    Replies: 11
    Last Post: 04-02-2009, 09:58 PM
  4. Finally broke into the 80's in salt water
    By Hecyan in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-21-2007, 05:50 PM
  5. RXP, SOLAS IMPELLER 13/19R or 14/19R in Salt water??
    By dre23 in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-24-2006, 06:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •