Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005

    Need more help OPAS removal and impeller cone question

    I suck at the search feature. I found a few things on installing the OPAS block offs but nothing to answer what to do with the water feed from the jet pump that lifted the OPAS paddles at speed.

    1. What do I have to block off and not for the water feed? I dont want to end up with a hull full of water LOL.

    2. My impeller cone after one ride came off the impeller and slid up the driveshaft. How can I stop that? Should I leave the impeller cone off? I am installing a 14/19 the 14/17 was to small but the cone should work on either correct? They are both Solas impellers...

    I am working on this right now. Please help.


  2. #2
    wettank's Avatar
    Join Date
    Mar 2011
    Location
    St Louis
    Posts
    211
    http://www.rivaracing.com/instructions/rs29985.pdf

    cone will work on either

    just plug the water feed

  3. #3
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4
    You can leave the nose cone off if riding in fresh water however would not advise this if you ride in the salt water it has been said you gain a bit more speed to.

  4. #4
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    What is the deal with the hex head screw your not supposed to remove? Mine is not flush so it holds the plate off the hull. Do I need to modify it or drill a hole in the block off plate or something.

  5. #5
    wettank's Avatar
    Join Date
    Mar 2011
    Location
    St Louis
    Posts
    211
    that hex head holds the mounting bracket to the inside the hull.clean up some of the silicone thats on it.The blockoff plate should have a indention in it that the hex head fits into so the plate mounts flush

  6. #6
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    I blocked off the 90 degree adapter going into the hull from the jet pump for the OPAS paddles by putting a hose with a bolt and a clamp on it. I went out for a ride and the OPAS hoses I left inside the hull are pumping my hull full of water. Has anyone seen this before? I thought all you had to do was block that 90 off I am looking at maybe putting a connection to just join the two hoses. THat should stop the water. I thought maybe something about that 90 might be broken making the water come in.

  7. #7
    wettank's Avatar
    Join Date
    Mar 2011
    Location
    St Louis
    Posts
    211
    did you for get to block off the other end like illustration #11 in the directions

  8. #8
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    I did I blocked both 90's by putting a piece of hose with a bolt in it and clamping it in there. Both ends should be blocked off. I assume the end in the jet pump just keeps the water from shooting out the hole and loosing jet thrust. The one going up into the hull carries the thrust to the OPAS system correct?

  9. #9
    wettank's Avatar
    Join Date
    Mar 2011
    Location
    St Louis
    Posts
    211
    Im pretty sure thats how it works,maybe there not sealed well enough

  10. #10
    Lock and Load tron's Avatar
    Join Date
    Jun 2007
    Location
    LAX, WI
    Posts
    259
    +1
    1

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 20
    Last Post: 07-03-2012, 11:39 AM
  2. I give, need more help 97 gp 1200
    By chritopherlloyd in forum Yamaha Old School Skis
    Replies: 21
    Last Post: 05-03-2008, 03:00 PM
  3. Need more help w/ new setup
    By Turbo Nick in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-30-2008, 02:34 PM
  4. Pump oil and impeller cones
    By Vern in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-23-2006, 03:40 PM
  5. Need More Help
    By RaystownLake GPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 03-19-2006, 07:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •