Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 37
  1. #1
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61

    new mods less performance. help

    I used to run an S3 wheel with 42's along with the rest of the mods in my sig. I would run 76+ all day and break 77 in colder weather.

    I just added an ET 137 charger, 48's, RRFPR and an AFR guage. The best I can get is 75mph @ 7960 - 8000 rpms.

    Could I have a fueling/tunning problem? My afr numbers are as follows:

    idle 12.5 - 12.7
    6000 rpm high 13's and touched 14+ a couple of times
    wot 11.1

    my RRFPR is set at 45lbs.

    Any ideas why I'm slower with a bigger charger?


  2. #2
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    Quote Originally Posted by h2jim View Post
    I used to run an S3 wheel with 42's along with the rest of the mods in my sig. I would run 76+ all day and break 77 in colder weather.

    I just added an ET 137 charger, 48's, RRFPR and an AFR guage. The best I can get is 75mph @ 7960 - 8000 rpms.

    Could I have a fueling/tunning problem? My afr numbers are as follows:

    idle 12.5 - 12.7
    6000 rpm high 13's and touched 14+ a couple of times
    wot 11.1

    my RRFPR is set at 45lbs.

    Any ideas why I'm slower with a bigger charger?
    Can you feel the power diff? more pull?

  3. #3
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    Boost gauge reading? without this you are going to be chasing your tail......a little rich at wot but u might have a boost leak. Make sure u are making more boost now and not less.....

  4. #4
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    It does seem to pull more but I would have thought that with 2 to 3 more pounds of boost I should gain a couple mph. My boost gauge read 9.5 with my S3 and almost 12 with my ET 137.

  5. #5
    MacDaddy_rxpx's Avatar
    Join Date
    Jun 2009
    Location
    Michigan
    Posts
    220
    +1
    1
    Try leaning the wot up a bit. Kinda rich.

  6. #6
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    I would have thought with this new charger that I would have had to add a couple of mm to my prop but I've lost rpm instead of gaining.

  7. #7
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    I know my wot is a bit rich but I was afraid if I took some fuel away I would be real lean at crusing speed since I'm already in the high 13's there.

  8. #8

    Join Date
    Jul 2010
    Location
    Daytona Beach
    Posts
    406
    you went up 2.5 lbs of boost but the rpm's went down? being a little rich shouldn't make that big of a difference.

  9. #9
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    running that rich will loose 200- 300 rpm..get the af right ..then decide...12 lbs ..you can go 79 80...i keep saying it the only way to properly tune a ski is with some sort of fuel controler..

  10. #10
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    You'r powerloss is in your rich afr at wot.
    I had the same problem,lost about 250 rpms,set the rrfpr to get afr aroun 11.8 - 11.9 and the rpm's came back.
    Speed did also increase,you have more power,just have to set the fueling right.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SHO "shutters" after new mods. Help!
    By BPnta in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 08-07-2009, 04:29 PM
  2. Need help with new mods
    By mozer in forum 4-Tec Performance
    Replies: 22
    Last Post: 11-10-2007, 12:59 PM
  3. New 15F. Best performance mods?
    By firehawk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 05-03-2007, 10:19 PM
  4. New Mods ->Water Test ->Need Help/Advice
    By 05RXPnoob in forum 4-Tec Performance
    Replies: 25
    Last Post: 04-29-2007, 10:39 AM
  5. thinking about some new mods...HELP
    By BlaZinMJ in forum 4-Tec Performance
    Replies: 7
    Last Post: 01-24-2007, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •