Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: 2006 RXT

  1. #1

    2006 RXT

    New to this forum and need some help. I have a 2006 RXT that I have had for two years. Excellent machine and have had no problems. I put a new battery on it this weekend, topped off the tank with premium and dropped her in the water. Babied her for a few minutes and noticed no problems. Then, when I accelerated I noticed she would accelerate, but not smoothly the whole time. I would get up to 45+ Mph and the RPMs seemed fine and then, all of a sudden, the RPMs would decrease down for a second or two. Then, the RPMs would increase again upward and seem ok for a few seconds and then would decrease down again. The craft never would stop or go way down in RPMs, though. I was still able to get close to 50 mph (I know this is not close to what I used to get) but am wondering if it could be the supercharger. I have 120 hours on the PWC. Can someone give me an idea where to start. I must admit that I did put a Yamaha battery in it that I had extra for one of my WaveBlaster IIs. Could this cause issues? Thanks in advance.


  2. #2
    Before you do anything else, drain out the gas and replace, then change the spark plugs. This is exactly what happens with old gas and bad plugs, see it every spring.

  3. #3
    I'll give it a shot. I had about 1/2 tank of gas that I had stabilized. I topped off with premium but didn't change the plugs. Do you think I could try new plugs and then change the oil first or should I just go ahead and drain and put new plugs in? What are symptoms of a supercharger starting to fail?
    Thanks,
    Marty

  4. #4
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    While your symptoms show possible signs of bad gas and fouled/old plugs, it could also be your SC. I'm guessing you bought it used if it's an '06 and you've had it two years...? Were the OEM SC washers upgraded and/or was the SC ever rebuilt? If no to the later two, you may def. have a SC problem. The only way you'll know for sure is to pull it and post up pix.

    Good luck and welcome to the forum.

  5. #5
    Thanks for the help. I read somewhere to test sc impeller by hand, if it spins, it's toast. Is this true?

  6. #6
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    Quote Originally Posted by jmrinlc View Post
    Thanks for the help. I read somewhere to test sc impeller by hand, if it spins, it's toast. Is this true?
    Yes, that is the easy test from what I've been told. It will pretty much free spin after a twist by hand.

  7. #7
    Melbourne (AUS) gtile04's Avatar
    Join Date
    Apr 2009
    Location
    Melbourne
    Posts
    567
    +1
    12
    so if i can spin my charger wheel by hand its toast

  8. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by gtile04 View Post
    so if i can spin my charger wheel by hand its toast
    While it is still bolted to the motor, yes. If it spins its toast.

  9. #9
    Melbourne (AUS) gtile04's Avatar
    Join Date
    Apr 2009
    Location
    Melbourne
    Posts
    567
    +1
    12
    Oh I have pulled the charger from the motor and it spins if I turn shaft wheel won't soon but I cM spin wheel by hand

  10. #10
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by gtile04 View Post
    Oh I have pulled the charger from the motor and it spins if I turn shaft wheel won't soon but I cM spin wheel by hand
    ? What?

    New plugs and gas and that first problem should be solved. Put a bottle of marine stabil in when putting up for the winter.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. (new here)2006 RXT
    By rocko672 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 10-02-2006, 11:52 AM
  2. 2006 RXT Disconnected Plug?
    By jfwsouth in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-15-2006, 02:54 PM
  3. 2006 rxt problem
    By davidl13 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-21-2006, 11:59 PM
  4. New Toy - 2006 RXT
    By KsharK in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 06-21-2006, 02:07 PM
  5. NOPASS 2006 RXT
    By ERICG in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-02-2006, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •