Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    04 gtx 30 mph top speed

    Seems like it is running fine, but it will only reach 6000 rpm's and go 30 mph. Checked plugs looked good, replaced last week, still no help. Just bought ski last month, so I don't know if this is normal. Didn't have key or ecu when purchased, so I had to buy both. Had key programmed by seadoo dealer. What could be causing this?


  2. #2

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    Perhaps the key was programed as the learning key ?

    I havent had any use for the two that came with ours. I dont recall if the display has a notice to that effect or not.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Piney View Post
    Perhaps the key was programed as the learning key ?

    I havent had any use for the two that came with ours. I dont recall if the display has a notice to that effect or not.
    Could be programed as a learner. If it aint the key, then your sc washers are toast. 6000 is when the boost kicks in. I have never run the learner key so I am not sure what rpm they limit the ski to.

  4. #4
    Doesn't have super charger, I will try to call dealer and ask about key, don't know why he would program that way.

  5. #5
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Sounds like the learner key. Needs to do a simple thing in buds.

  6. #6
    Dealer says key is right

  7. #7
    Any idea what else it could be?

  8. #8
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    Quote Originally Posted by joey0909 View Post
    Any idea what else it could be?
    whats your idle rpms like?

  9. #9
    It idles about 1800

  10. #10
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    Quote Originally Posted by joey0909 View Post
    It idles about 1800
    if 1800 steady then its probably not a coil problem. maybe something in the pump or prop is working itself loose. but if its cutting at exactly 6k and 30mph then it sounds like the learners key. did you get 2 keys? try both of them?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 09 SHO lost 15 mph top speed
    By Sikes44 in forum Yamaha PWC Performance (4-stroke)
    Replies: 20
    Last Post: 02-16-2013, 03:39 AM
  2. GP1200R 2001 Powervalve not opening 56 mph top speed
    By Gpr1200_NC in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 06-06-2012, 08:23 PM
  3. GTX 4 TEC top speed concerns
    By Biglove666 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-28-2009, 06:25 AM
  4. 50 mph top speed ?
    By ssvincels1 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-21-2007, 12:24 AM
  5. 70 mph top speed
    By Gareth in forum 4-Tec Performance
    Replies: 26
    Last Post: 02-08-2007, 06:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •