Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005

    Speed Question after mods

    I have installed an X charger 42# injectors 4" front air kit 14/19 Solas prop Riva intake grate 2* pump wedge Reverse bucket mod, OPAS block offs. I have an 06 RXT 70 degrees out today and 69 degree water. Rider 275 Lbs 67.4 MPH best GPS speed. I guess I was looking for more. Is this right in your opinion for the mods? I want to add RRFPR and Fizzle intercooler and have speedfreaks do my ride plate. Any ideas of gains above what I have now? My wear ring had a few grooves but nothing I thought was that bad. Could I be losing a MPH or so there?


  2. #2
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15
    Rpms?

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by b_dolla44 View Post
    Rpms?
    +1

    My 06 RXT I used to have ran 69.5 with just a Riva stg1.

  4. #4
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    I start out at 8140 and I think heat soak takes me down to 7980 on a long run, but I am running 8100 pretty consistant again unless a really long run. I was thinking that was slow compared to others that I have seen. Trying to find where I am losing. I didnt think 8100 was that bad and 8140 I think gave me the best speed of 67.4 I had a 14/17 before but was turning 8200 at about 1/2 inch from the handle bar not hitting rev limiter but 1/2 inch of throttle made no real difference so I stepped up to 14/19 and left the nose cone off.

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Rpm's are in the right range.

  6. #6
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    I am also looking at possibly doing speedfreaks setback mod to the prop. Would a new wear ring bring my RPMs down or up and would that explain my speed loss? Should I get a Seadoo one or a cheapy from SBT or something. Short of getting an AFR gauge and a boost gauge (I will be getting them later with a cool lid that I found a guy on here makes) I think I used a setup that is pretty bullet proof as far as AFRs etc so I was hoping to get that stuff later. I am trying to get 69 out of what I have now and build on that.

  7. #7
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    Do you think the wear ring could cause that much speed loss? I dont see it worn that much. Just some small scratches from the impeller. Will my RPMs go up or down if the wear ring is replaced and is some of the trouble?

  8. #8
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1
    A tighter wear ring will bring your RPM's down, yet bring your speed up. is there a groove in the ring? some people talk about flipping them, mine never come out that pretty, I just replace.
    What type of air intake and exhaust do you have do you have?

  9. #9
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Sounds right to me. Stock 07 RXT original everything 190 hrs 60mph (I weigh 175)

    Looking at the X charger and 42lb injectors also.

  10. #10
    race24x's Avatar
    Join Date
    May 2007
    Location
    Fayette, Maine
    Posts
    1,005
    I have a 4" custom front air intake, and I am using the stock exhaust.

    XDaily I think from what I have read on here in the past 60 MPH is pretty low. Mine was 65 MPH stock and my buddies 05 RXT is about 66 MPH stock his GTX is about 64 MPH stock.

    I dont know if this is a clue, but if I punch it from a stop it hits the rev limit 4 or 5 times before it catches and goes. I assumed with the added power that was causing this as it did not do this before the X Charger and Injectors and I added the new Sola Prop

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Have a question about my speed with current mods
    By orlandohondarider in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 08-14-2015, 04:42 PM
  2. 2010 fzs top speed problem after mods
    By straightshot223 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-23-2015, 04:29 PM
  3. GTS 130 GPS'd speeds before/after mods
    By ryanr623 in forum 4-Tec Performance
    Replies: 19
    Last Post: 01-28-2015, 05:20 PM
  4. Amazing speed after mods
    By Otacon132 in forum 4-Tec Performance
    Replies: 24
    Last Post: 06-15-2010, 01:39 PM
  5. 04 rxp speed after mods ?
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-10-2008, 08:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •