Results 1 to 5 of 5
  1. #1
    tburn's Avatar
    Join Date
    Jun 2007
    Location
    E.WATERBORO MAINE
    Posts
    109

    2001 Virage TXi engine problems

    I am working on this for a friend, it has a melted piston on the middle cylinder. It looks to be detonation but, the whole top of the piston looks like it has been sand blasted right down to the top ring and the other two cylinders are fine. I have not done any tests yet to see what might have caused this but, I also have never worked on an injected one either. Any suggestions or help would be great on what to look for. Thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Check for damage or debris in the crank case. Connecting rod bearing pieces (or broken piston ring or piston pieces) may have been banging around in the combustion chamber.

    Eliminate all the mechanical possibilities before looking at the fuel injection system.

  3. #3
    tburn's Avatar
    Join Date
    Jun 2007
    Location
    E.WATERBORO MAINE
    Posts
    109

    virage engine problems

    There is no damage other than the top of the piston is sand blasted right down to the top ring. 99% of the piston when out the exhaust. I was just wondering if the middle injector failed or if there is a problem in the EMM? Thanks Tom

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    What does the cylinder head look like?

    Injector or EMM problem might cause it to run lean. Somehow I would expect lean to show up more as a hole in the piston dome rather that damage around the piston perimeter.

    Post up clear photos of piston, cylinder and head?

  5. #5
    tburn's Avatar
    Join Date
    Jun 2007
    Location
    E.WATERBORO MAINE
    Posts
    109

    virage problem

    The head is pitted up as well. I will take some pics after work and post them. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Virage txi engine cuts out at full throttle
    By Brookie in forum Polaris PWC Performance
    Replies: 11
    Last Post: 08-12-2013, 08:27 AM
  2. 2001 Virage txi problems
    By gogregerson in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-24-2011, 12:53 PM
  3. FS 2001 polaris virage txi engine harness
    By 2&4strokepolaristech in forum Polaris Classifieds
    Replies: 1
    Last Post: 10-04-2009, 12:47 AM
  4. 2001 Virage TXi Problems - Need Advice
    By way2much2do in forum Polaris Open Discussion
    Replies: 24
    Last Post: 07-17-2009, 04:37 PM
  5. 2001 Virage TXI Fuel Problem, I THINK???
    By axman19 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-05-2008, 08:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •