Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32

    I'm back!! With qurestions too!

    Hey Guys I'm part of the SeaDoo community again, I just bought an 06 RXT. I have some quick questions about it.
    Did 06's come with metal washers? and secondly: Could bad fuel cause erratic RPM'S? When I test drove it, I initially couldn't get it above 6300. It was very sluggish. We took it back, I checked the SC hose"it was still on" Checked the plugs etc. We didn't find anything. The guy put some dry gas in, and we ran it on the hose for awhile.
    We took it back to the lake and I was able to hit 8120rpms but the sluggishness would come and go. I went ahead and bought it thinking that as long as I was hitting my peak rpms that it probably isn't too serious. Aside from getting the old storage gas out, and getting nice fresh fuel in, is there anything else that could be my problem?

    Anyway, It's nice to be back. Hopefully I won't be starting a major repair thread.

    P.S. think it will need paint?


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    new plugs and check the intercooler it could be leaking.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Welcome back.

    NO, they have ceramics

  4. #4
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53
    Did you try changing out the plugs? That might fix your problem.

  5. #5
    Everthing louder than everything else! sHALlow's Avatar
    Join Date
    Jun 2010
    Location
    Panama City, FL
    Posts
    391
    +1
    27
    Quote Originally Posted by troyheb View Post
    Welcome back.

    NO, they have ceramics
    +1. sounds like an issue i had, it was a bad coil pack. how does it idle? time to change that sig from skiless.

  6. #6
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Quote Originally Posted by troyheb View Post
    Welcome back.

    NO, they have ceramics
    Thanks bro

    Sounds like I'm gonna need some washers. I'll replace the plugs tomorrow.

    Quote Originally Posted by sHALlow View Post
    +1. sounds like an issue i had, it was a bad coil pack. how does it idle? time to change that sig from skiless.
    It idles pretty good. It did seem to "sputter" occasionally. "and I changed my sig!"

  7. #7
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Quote Originally Posted by mrbtd View Post
    new plugs and check the intercooler it could be leaking.
    How would I check the intercooler?

  8. #8
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,693
    +1
    40
    Quote Originally Posted by sn-95 View Post
    How would I check the intercooler?
    Change the plugs and loose the clamp that hold the cooler on the manifold.Then pul it out and see if there is any water on it.
    Check also the airbox as it has some plastic parts in it that broke and clogs the intake hose!

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    I cannot talk to you until you paint something and or put paint on that ski.... Sorry... It's the rules.

  10. #10
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Quote Originally Posted by mitsakosgt View Post
    Change the plugs and loose the clamp that hold the cooler on the manifold.Then pul it out and see if there is any water on it.
    Check also the airbox as it has some plastic parts in it that broke and clogs the intake hose!
    I will try that ,Thanks!




    Quote Originally Posted by MSRXP View Post
    I cannot talk to you until you paint something and or put paint on that ski.... Sorry... It's the rules.
    It's surprising how often I hear that

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I'm back with a new ski 2013 FX-HO.
    By abracadabra in forum Yamaha PWC Performance (4-stroke)
    Replies: 133
    Last Post: 05-06-2015, 03:17 PM
  2. Got my ultra back with the looks mods
    By official_style in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 08-15-2014, 06:45 PM
  3. " Back With Dinner"
    By jetskibrian in forum PWC Fishing
    Replies: 3
    Last Post: 08-15-2012, 08:51 PM
  4. Seat pan warped, can it be bent back with heat?
    By Juscruzn in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-23-2011, 03:26 PM
  5. Got my revenge back with the GP1300R's that spanked me!!!
    By NeverEndn in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-16-2006, 10:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •