Results 1 to 2 of 2
  1. #1

    Bog at idle speeds

    Once I have it started the GP1200r it doesnt run very well at idle and wants to bog down unless I feather the throttle. Once I get past idle speeds it runs great, any suggestions on how I can fix this problem? It was just dewinterized a few weeks ago and I just changed the spark plugs, installed PPK and new impeller.

  2. #2
    My ski always works sometimes... griffin55's Avatar
    Join Date
    Jul 2009
    Milwaukee, WI
    I just responded in your other thread . Mine does the same thing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Raider 1100 off idle bog after primer install , help
    By junny in forum Yamaha Old School Skis
    Replies: 20
    Last Post: 09-07-2011, 10:04 PM
  2. 98 GP 800 - Runs at idle to mid and than full bog
    By jchale in forum Yamaha Old School Skis
    Replies: 21
    Last Post: 06-13-2011, 04:37 PM
  3. 2008 STF-15x is running rough at idle to low speeds
    By geissap in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-19-2010, 11:10 AM
  4. Sporadic engine power at idle speeds.
    By allin in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 09-26-2007, 07:21 AM
  5. fast idle speeds
    By wakeborder556 in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-16-2006, 11:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts