Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1

    Oil on engine above supercharger shaft entrance

    I have an 04 RXP w/mods below. I am seeing a small amount of oil on the engine right above where the supercharger gear enters the engine. At first I thought my oil filter cap was not tight enough, but it doesnt seem to be coming from there, any ideas?

    I have photos now, maybe these will help...

    gaskets have no oil on them, not much of anything in catch can after a tank of fuel, no oil in charger, and i can barely spin it a little by hand before pulling...

    No clue, my only idea is the o-rings on the SC housing...

    and does my shaft seal look correct? It came out and I re-installed it when I was building,

    I checkes all over, electrical, bolts....

    Still a good amount of oil in the hull after a ride... drains out like chocolate milk...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0648.jpg 
Views:	72 
Size:	88.1 KB 
ID:	244919   Click image for larger version. 

Name:	IMG_0644.jpg 
Views:	64 
Size:	118.7 KB 
ID:	244918   Click image for larger version. 

Name:	IMG_0642.jpg 
Views:	59 
Size:	101.4 KB 
ID:	244915   Click image for larger version. 

Name:	IMG_0641.jpg 
Views:	55 
Size:	88.2 KB 
ID:	244922   Click image for larger version. 

Name:	IMG_0645.jpg 
Views:	58 
Size:	150.3 KB 
ID:	244913   Click image for larger version. 

Name:	IMG_0646.jpg 
Views:	50 
Size:	148.2 KB 
ID:	244917  

    Click image for larger version. 

Name:	IMG_0639.jpg 
Views:	54 
Size:	91.5 KB 
ID:	244916   Click image for larger version. 

Name:	IMG_0647.jpg 
Views:	55 
Size:	98.9 KB 
ID:	244921   Click image for larger version. 

Name:	IMG_0650.jpg 
Views:	54 
Size:	94.8 KB 
ID:	244920   Click image for larger version. 

Name:	IMG_0640.jpg 
Views:	53 
Size:	75.5 KB 
ID:	244914  
    Last edited by geowelsh; 07-08-2011 at 05:33 PM. Reason: PICTURES ADDED


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    How are the two oil seal-o rings on the Scer housing???Hows the valve cover gasket???I would start with these first.

  3. #3
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1
    valve cover is good, I am going to pull the SC tomorrow, thats about the last place I think it could be, didnt start until I installed the rude. the o-rings there are the only protection against this, correct? If thats the case I'll just replace them and go with it to see if it happens again.

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Cam shaft cap

  5. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    I had oil leaking out of the stator wire grommets, that come out the top of the PTO cover once....

    Cleaned it real good with some brake cleaner, and put some Right stuff sealant around them, and it stopped.

  6. #6
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1
    Good ideas, I will check all these, it'll be alot easier when I get the SC'er out of the way...

  7. #7
    boosted-delslow's Avatar
    Join Date
    Jun 2010
    Location
    delaware
    Posts
    231
    +1
    1
    Mine weeps a little oil from the stator groumets to. Nothing major. Just enough to collect a little dirt so it is noticeable.

  8. #8
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1
    PICTURES ADDED, only idea I have is the SC o-rings...

    I am stumped

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Did you check the rubber pto bearing coupler for tears or a small hole??Thats alot of oil to be coming from the Scer...If it was leaking that bad you would see oil on the block...

  10. #10
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1
    no, I haven't, good idea though, I put a hoseclamp on the cover when it came out, I may have tore it. I will look in a bit...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 09-13-2011, 10:22 PM
  2. How many hours on your 4tec supercharged engine?
    By dav_dman in forum Sea Doo Open Discussion
    Replies: 43
    Last Post: 01-28-2009, 02:48 AM
  3. needs some advice on supercharger Shaft?
    By superblownrxp in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-27-2008, 09:47 PM
  4. Engine Side of Supercharger Shaft
    By RXP04 in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-16-2007, 12:07 PM
  5. Compression on 4-Tec Supercharged Engine
    By ramnj in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-22-2006, 08:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •