Results 1 to 6 of 6
  1. #1

    95 SL 750 Lose power when turning any thoughts??

    have a 95 polaris Sl750 its been stored for 3 years, ran fine when put up, it will plain out and runs up to full speed in a straight line,but when i try to turn it will lose power. it dont sound like it missing or running bad just no power..anyone what is going on here?


  2. #2
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Loss of power like that sounds like a lack of fuel delivery.

    3 years of storage can dry out flexible parts like carb diaphragms, fuel pump diaphragms, etc and play havoc on rubber components. I would strongly urge you make a complete run through the fuel system replacing fuel lines, rebuild kit in the carbs, and also the fuel pump. If you're still on the OEM fuel pump, make the upgrade to a 3-outlet. Also check the oil lines and if they have hardened you should replace those as well.

    KJ

  3. #3
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Welcome to Hulk!

    Once finish going thru fuel delivery system, if problem still exists you can try these carb tuning tips.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    Welcome

  5. #5
    97 Kawasaki STX 1100
    Join Date
    May 2010
    Location
    Idaho
    Posts
    163
    Quote Originally Posted by jerry345 View Post
    have a 95 polaris Sl750 its been stored for 3 years, ran fine when put up, it will plain out and runs up to full speed in a straight line,but when i try to turn it will lose power. it dont sound like it missing or running bad just no power..anyone what is going on here?
    Sounds like you could have a electrical problem. Check all your connections. Unplug them and then reconnect them. If the ski sits and idles and runs great on full excelleration but then cuts out on hard turns I would think you have a electrical issue...

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Does it do it when turning hard in both directions or just 1?

    Hard left, hard right, or both?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SL 750 Loses Power and Drops to Idle
    By Alex-7 in forum Polaris Tech Tips and Info
    Replies: 3
    Last Post: 04-15-2013, 10:23 PM
  2. 260x loses power when turning left! HELP!
    By thead in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 05-02-2010, 09:15 PM
  3. 95 sl 750 wont rev
    By waverunner in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 06-20-2007, 09:41 PM
  4. Removing Pump from rear of 95 sl 750
    By sweetcoupe in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-12-2007, 11:41 PM
  5. 95 SL 750
    By chipeia in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-30-2007, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •