Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jul 2011
    Location
    Boone ,NC
    Posts
    8

    93 SL750 no spark

    Will a CDI box from a 95 SL750 work on the 93? If so, how would I go about wiring it up?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome

    There were some differences between the early and later year 650 ignition systems. One of the Fuji guys should be able to answer the question.

    Edit: I mis-read the engine size

  3. #3

    Join Date
    Jul 2011
    Location
    Boone ,NC
    Posts
    8
    I just bought and the PO said that his son tried to hook it up but couldn't get it to run so they gave up on it and sold it. The engine is brand new (crate). Also bought the 95 as a combo. If all else fails, could I take the stator off the 95 to get the 93 to accept the 95 CDI? Sorry for all the questions. I have owned and worked on several H-D bikes but, this PWC is a first for me and I'm willing to learn. Shay

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Do you have two SL750 watercraft? One a 1993 and one 1995?

    There are some differences between those model years other than the ignition system.

  5. #5

    Join Date
    Jul 2011
    Location
    Boone ,NC
    Posts
    8
    yes , the 95 is more or less for parts.
    Quote Originally Posted by K447 View Post
    Do you have two SL750 watercraft? One a 1993 and one 1995?

    There are some differences between those model years other than the ignition system.
    The 95 has the digital gauges and the 93 has analog.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by Shaymus View Post
    yes , the 95 is more or less for parts.

    The 95 has the digital gauges and the 93 has analog.
    The 1995 also has the much better 148mm modular jet pump, and the engine cooling is simpler with no water jacket in the crank case.

    1992 and 1993 were the first two years of production for Polaris PWC, and there were a bunch of improvements that happened starting in 1994.

  7. #7

    Join Date
    Jul 2011
    Location
    Boone ,NC
    Posts
    8
    the 95 has low compression on one of the cylinders but , the 93 has a new engine in it. The PO said it only has 3 hrs on it.It even has the plastic cover over the air cleaner, so that is why I'm trying to get it running.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    You can move the newer jet pump onto the older hull, for a performance gain.

    Also can move the MFD display and related wiring over if you want.

  9. #9

    Join Date
    Jul 2011
    Location
    Boone ,NC
    Posts
    8
    Update: I got it to fire with the other CDI box. Now I need to know , Do I hook the coils in a sequence like the manual shows ? or Do I hook the coils inline with the way the heads are numbered (which makes better sence to me).


  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    On the blue Fuji engines all three ignition coils fire together every time any cylinder needs spark.

    As far as I know it makes no difference which ignition coil is connected to which cylinder.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 polaris sl750 no spark
    By boatman606 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-24-2013, 05:31 AM
  2. 93 seadoo no spark
    By crazyaces in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-12-2009, 05:57 PM
  3. 95' SL750: No spark!
    By SeaBee63 in forum Polaris Open Discussion
    Replies: 19
    Last Post: 07-18-2007, 12:06 AM
  4. 93 SL750 no low end
    By AJS750 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 07-09-2007, 11:39 PM
  5. SL750 No Spark
    By KKubacki in forum Polaris Open Discussion
    Replies: 18
    Last Post: 06-01-2007, 02:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •