Results 1 to 4 of 4
  1. #1
    RXP85's Avatar
    Join Date
    Sep 2009
    Location
    IL
    Posts
    207

    Need Help Please, RXP starts, but when you give it gas it wants to die down!

    Hey guys, I am trying to help my buddie get his ski going, he has an 06 rxp, the ski fires up right away, but when you give it gas, it just bogs down and sounds like its going to die down. He took it out there other day, let the ski warm up for a few min, then at WOT the ski only did 40mph, then I think after the new gas got through the lines it ran normal. Now he took it out the other day and it bogs and goes practically no where when gving it gas. I hope I explained this good enough for you to understand. The ski has no mods on it, all stock and has around 71 hrs on it. I am going to try new plugs in it tonight and see if that works. Any suggestions will be helpful! Thanks in advance.


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Change the plugs, check the prop and ensure it is tight. 95 ft lbs I think. ??? Check the wear ring as well and make sure nothing is lodged in the pump. It sounds like it is running on 2 cylinders or that one is not firing as it should. Hope it helps.

  3. #3
    RXP85's Avatar
    Join Date
    Sep 2009
    Location
    IL
    Posts
    207
    Quote Originally Posted by MSRXP View Post
    Change the plugs, check the prop and ensure it is tight. 95 ft lbs I think. ??? Check the wear ring as well and make sure nothing is lodged in the pump. It sounds like it is running on 2 cylinders or that one is not firing as it should. Hope it helps.
    I know the wear ring is a little beat up, but nothing is stuck in it, I will make sure the prob and all is tight also. Thanks for the tips!

  4. #4
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    look at the plugs very closely when you change them. If one is a different color than the others you may have a coil problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NEED help please>>>Jerry i need to contact you
    By Emol:TX in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-31-2015, 07:24 PM
  2. 1992 sl 650 starts right up but turns off when u give it fuel please help
    By fryestyle16 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-07-2013, 10:13 PM
  3. Please need help!! 2007 rxp!!
    By Seadooracer101 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-26-2013, 08:29 AM
  4. Need Help Please 718 won't start
    By GGG in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-31-2011, 12:05 PM
  5. Replies: 2
    Last Post: 03-26-2011, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •