Results 1 to 2 of 2
  1. #1

    06 rxp VTS studdering

    My VTS acting strange. Sometimes it will go up and down fine, other times it will go up and inch and then stop. It will always go down all the way, but sometimes it goes up only that 1 inch. Everything appears to be correct back there an all electric looks good.

    Im lost. All help is greatly appreciated!

    Thanks


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    u may have to pull the cover , and inspect the motor for broken mounts, or binding gears. Do u wave jump, landing tail first??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 06-12-2011, 08:29 AM
  2. 06 RXP VTS power trim not working
    By 8kgold69 in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-22-2010, 06:25 PM
  3. 06 RXP VTS Issues...HELP!
    By pjr170 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-08-2009, 08:45 AM
  4. WTB VTS Motor for 06 RXP
    By CarFanatic in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-13-2009, 10:41 AM
  5. 06 RXP VTS Problems
    By Antiguan FZR in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-20-2009, 09:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •