Results 1 to 6 of 6
  1. #1
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59

    2010 RXTX hood shock fail

    Opening the hood yesterday "carefully" and felt/heard a little pop. watta ya know....
    Shock tabs broke. I remember a guy complaining last year about it.
    Here are some pics. As you can see - very poor design. The bottom tabs are tweaked too.
    I'm thinking about drilling and throwing a hitch pin or equivalent in there unless someone else has a better fix. I don't want to "warranty" it and have it break again.
    Click image for larger version. 

Name:	IMG_0135.jpg 
Views:	178 
Size:	22.4 KB 
ID:	244245Click image for larger version. 

Name:	IMG_0136.jpg 
Views:	165 
Size:	25.8 KB 
ID:	244249Click image for larger version. 

Name:	IMG_0137.jpg 
Views:	150 
Size:	27.5 KB 
ID:	244247Click image for larger version. 

Name:	IMG_0133.jpg 
Views:	138 
Size:	45.9 KB 
ID:	244248Click image for larger version. 

Name:	IMG_0134.jpg 
Views:	154 
Size:	42.9 KB 
ID:	244250


  2. #2
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,994
    +1
    455
    I responded to your other post

  3. #3
    That would be me who "complained" about it last year. Quick warranty replacement, but the crappy part was I had to tow the ski the half hour to the dealer, let them verify the damage, order the part, then install it on the ski. They wouldn't allow me to simply carry in the part and swap it out myself - something about warranty claims must be completed by their authorized service techs.

  4. #4
    immred's Avatar
    Join Date
    Jul 2007
    Location
    Manassas VA
    Posts
    154
    +1
    1
    Mine broke also after about 3 months. One of the storage bin locks broke also. My dealer got them for me on warranty and let me replace them.

  5. #5
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,994
    +1
    455

  6. #6
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    I did the same thing Scott

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 RXTX 260 failing under high rpm
    By Pete1027 in forum 4-Tec Performance
    Replies: 27
    Last Post: 12-26-2013, 07:06 PM
  2. RXTX hood shock/lift cylinder wont.....
    By mstennes in forum 4-Tec Performance
    Replies: 15
    Last Post: 08-17-2009, 09:38 AM
  3. RXTX Hood shock keep poping off
    By driveumhard in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-05-2008, 08:51 AM
  4. 03 GTX 4 TEC hood shock problems
    By mandtra in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-20-2007, 05:10 PM
  5. Help with the Hood Shock Rod thingy...
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 05-26-2006, 12:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •