Results 1 to 9 of 9
  1. #1

    Help, my 2008 SHO Cruiser won't go over 40.

    On pretty much the last ride last season, my Waverunner, which I GPS measured at about 66 MH when it was new, would no longer go over 40.

    I assumed I destroyed the impeller with rocks, but I just examined it, and it looked ok.

    It behaves as if the "leaning mode" is on, but it is not.

    Could it be electrical where it thinks learning mode is on?

    It has maybe 60 hours on the engine.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Is it reaching full RPM?

  3. #3
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    Sounds like the clutch is shot. See if it turns both ways, if so then you'll need a new clutch. Just make sure you are certain you are not in learning mode. It's easy to over look. Also, if your pump/ prop sucked up rocks then you would have some bad cavitation on take off.

  4. #4
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    One of two things pop to mind.

    1. A hose came off for the intake - Check all hoses, particularly the one from the supercharger to the intercooler.
    2. The supercharger clutch failed - With the motor OFF take the intake hose off the front of the supercharger. If the SC wheel spins both ways the clutch is toast.

  5. #5
    Are you both talking about the same clutch?

    When you say SC wheel spinning, what do you do to make it spin?

    I will go test the RPM.

  6. #6
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    Quote Originally Posted by rsilvers View Post
    Are you both talking about the same clutch?

    When you say SC wheel spinning, what do you do to make it spin?

    I will go test the RPM.
    Yes we mean the same clutch. Take off the hose that goes from the airbox into the SC and put your hand in there with the engine off and see if the wheel spins both ways. It shouldn't.

  7. #7
    6200 rpm at max speed, which is indicated as 42 MPH.

    No loose hoses.

    I took off the intake to the supercharger and it easily spun freely in both directions with no resistance, as if it were a turbo.

    How hard is it to put in the clutch?

    What parts are needed?

    How much does a dealer charge to do it all?

    Thanks.

  8. #8
    I can't find the part on the diagram. The only clutch listed is inside the crankshaft. Anyone know the part number?

  9. #9
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    It's not that hard. Time consuming and must be done right though.

    http://www.greenhulk.net/forums/show...utch-explained

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP!! VX110 won't go over 35 mph
    By terkkata in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 06-19-2010, 01:01 PM
  2. 2008 VX cruiser rpms won't go over 5,000
    By carms_us in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-03-2010, 12:35 PM
  3. 65.7mph, 2008 SHO Cruiser (23.4hrs)
    By Toobold in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 09-09-2009, 03:49 AM
  4. HOPE my new SHO Cruiser will out run this:)
    By Toobold in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 01-28-2009, 10:54 AM
  5. HELP!!!!!!!!2 Ultra 250's won't go over 50!!!!!!?????
    By chelp2525 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 05-21-2007, 03:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •