Results 1 to 4 of 4
  1. #1

    Fresh Rebuild doesn't run smooth.

    I bought a used 06 about a year ago. The ski never ran and after some investigating I found that the rings were frozen. Long story short I pulled the motor and rebuilt it bottom up. Bored cylinders, new bearings, etc. Just put it back together and it runs but runs poorly. I suspected timing and went in and double checked the gear locations and everything is in line. Now I suspect it may be is the cam chain tensioner. When I used the tool with it on the bench it moved in smoothly and would release immediately when I released pressure on my fingers holding the tool. However after installing the tensioner it felt like it didn't unwind much and I could even put additional pressure on the tensioner with the tool by turning counter clockwise. Funny the ski runs but is rough however every once in a while it runs perfect. I am curious if the tensioner is not working properly and messing up the timing. Then when it hits the "right" spot it runs smooth. Any thoughts?

    Thank you for taking the time.


  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    Did you put new plugs in it? Sounds like you have a fouled one.

    Shawn

  3. #3
    All new plugs with the rebuild. I might have to try unplugging one coil at a time to see if I might have a bad one.

  4. #4
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    Give us all 4 compression readings also.

    Shawn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS GP1200 fresh rebuild minor mods no engine mods runs out great PA
    By vettez062002 in forum Yamaha 2 Stroke Skis
    Replies: 17
    Last Post: 08-30-2010, 08:10 AM
  2. max number of shims on fresh rebuild
    By masta2000 in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-03-2009, 07:06 PM
  3. FS: Riva S3 complete supercharger 0hrs. on fresh rebuild
    By boostaholic in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 06-26-2008, 12:51 PM
  4. Raves on fresh rebuild 1mm over size
    By cdcats in forum 2-Stroke Performance
    Replies: 1
    Last Post: 02-03-2008, 09:16 AM
  5. genesis 1200 doesn't run above idle
    By kingjon3rd in forum Polaris Open Discussion
    Replies: 9
    Last Post: 08-14-2007, 08:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •