Results 1 to 2 of 2

Thread: engine problems

  1. #1

    Angry engine problems

    hi im a new jetskier i bought a second hand jetski kawasaki ultra 150 year 2000 i think it starts out of the water but not in the sea a friend sugested a new battery but still the same i hope someone can help me thanx aj

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    aj, you're gonna have to do better than that. If it starts on the trailer, that's good. You can safely run it without water for about 15 seconds. Do that, then put it in the water and try it.

    If it doesn't crank reliably, then you might need a new battery. If it runs on the trailer, but not in the water, you're probably looking at overhauling the carburetors. Try a new fuel filter before doing that, however.

    Remember, if you run the engine on the flush hose, NEVER run the water unless the engine is running. Start the engine, turn on the water. Turn off the water, THEN turn off the engine. Allowing the water to run without the engine running can cause major damage to the engine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine Removal Problems
    By mikeysso in forum 2-Stroke Performance
    Replies: 5
    Last Post: 08-02-2010, 03:30 PM
  2. 800r engine problems
    By jeepsrdreaming in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 11-12-2009, 09:30 AM
  3. Rxp engine problems
    By rxp_kimmo in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 08-01-2008, 10:37 AM
  4. SL 750 94' Engine problems
    By jfrelin in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-22-2008, 12:19 AM
  5. Update: Engine/SC problems
    By Watdog in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-09-2008, 01:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts