Results 1 to 7 of 7
  1. #1

    2004 RXP wont charge

    Hello, would like a little info on my RXP. I have 12v low message and warning light on then machine eventually died. Hauled home checked battery. Charged and load tested (also 2 months old) it was fine. Next step took regulator/rectifier off wifes 06 wake (p/n's were the same and hers is working fine) plugged it in and no increase in voltage on battery. What next stator replacement? If so any idea of how much? And/or how diffucult?


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Check your 30a fuses on the upper left side of the MPEM, above the starter selenoid

  3. #3
    Yes I did they weren't blown or lose. Any other ideas anyone. Thanks

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Welcome to the Hulk.

    Next step check the stator. If it needs replacing its time to pull the motor..

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673

  6. #6
    Well bad news I tested harness at rectifier and also at plug right out of engine. No resistence of any kind. Debating on getting manual and pulling engine myself. Any ideas on what else I should look at while I am in there? Has 132 hours on it.

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    fly wheel bolts

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 rxp wont charge while running
    By mike9812121298 in forum 4-Tec Performance
    Replies: 18
    Last Post: 09-13-2015, 03:31 PM
  2. 2004 rxp engine swap wont start
    By redrocketcrawler in forum 4-Tec Performance
    Replies: 5
    Last Post: 11-03-2014, 11:13 AM
  3. 2004 ultra 150 wont charge battery
    By pjohnsontsm in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 01-30-2012, 09:49 PM
  4. 2004 RXP Paint Codes
    By Thomas in forum Sea Doo How To & FAQs
    Replies: 5
    Last Post: 07-23-2007, 12:14 AM
  5. RXP WONT FLOAT: WTF
    By HankC350 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-20-2005, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •