Results 1 to 7 of 7
  1. #1

    2004 RXP wont charge

    Hello, would like a little info on my RXP. I have 12v low message and warning light on then machine eventually died. Hauled home checked battery. Charged and load tested (also 2 months old) it was fine. Next step took regulator/rectifier off wifes 06 wake (p/n's were the same and hers is working fine) plugged it in and no increase in voltage on battery. What next stator replacement? If so any idea of how much? And/or how diffucult?

  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Port St. Lucie, FL
    Check your 30a fuses on the upper left side of the MPEM, above the starter selenoid

  3. #3
    Yes I did they weren't blown or lose. Any other ideas anyone. Thanks

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Welcome to the Hulk.

    Next step check the stator. If it needs replacing its time to pull the motor..

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Tampa Bay, FL

  6. #6
    Well bad news I tested harness at rectifier and also at plug right out of engine. No resistence of any kind. Debating on getting manual and pulling engine myself. Any ideas on what else I should look at while I am in there? Has 132 hours on it.

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    west texas
    fly wheel bolts

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help!! 2004 GTX 4 tec SC Wont Start
    By eddyk117 in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-15-2011, 08:44 AM
  2. 99 XPL Wont Charge
    By tall1 in forum 2-Stroke Performance
    Replies: 9
    Last Post: 06-23-2009, 12:19 PM
  3. 2004 HO wont start
    By seamac in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 04-24-2009, 09:49 PM
  4. 2004 Sportster 4TEC Wont Start
    By tonyt7482 in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 03-15-2009, 07:26 PM
  5. 95 slt 750 wont charge
    By The Joker in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 12-13-2006, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts