Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Clear the air space! MKaman's Avatar
    Join Date
    Jul 2007
    Location
    Feasterville, PA
    Posts
    1,531

    Exclamation Ultra 300 Throttle Issue

    I had an unusal and disturbing happening over the weekend while doing some lake riding.

    Could be potentially dangerous

    Throttle would not return to normal idle. It held at 2500 to 3500 rpm and it is a thouttle cable issue and ALL should be aware and cautious. It is in the spool that returns the throttle to idle where I found the issue.

    I have not corrected it or solved it as of yet, didn't have time to work on it but will let eveyone know the how and what in the next coming days.

    Not likely a big deal, I'm expecting an adjustment of some nature.


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,166
    +1
    602
    Quote Originally Posted by MKaman View Post
    I had an unusal and disturbing happening over the weekend while doing some lake riding.

    Could be potentially dangerous

    Throttle would not return to normal idle. It held at 2500 to 3500 rpm and it is a thouttle cable issue and ALL should be aware and cautious. It is in the spool that returns the throttle to idle where I found the issue.

    I have not corrected it or solved it as of yet, didn't have time to work on it but will let eveyone know the how and what in the next coming days.

    Not likely a big deal, I'm expecting an adjustment of some nature.
    just guessing but is it the KSS system ?

    as it is way more obvious over the earlier ultras

    Waz

  3. #3

    Join Date
    Feb 2009
    Location
    Pensacola Fl
    Posts
    235
    +1
    1
    My idle has been sticking a bit high too. About 2500 rpms for a few seconds before it drops down, or until I goose the throtttle which also seems to un stick it. Does not do it all the time.

  4. #4
    Clear the air space! MKaman's Avatar
    Join Date
    Jul 2007
    Location
    Feasterville, PA
    Posts
    1,531
    Quote Originally Posted by sirbreaksalot View Post
    just guessing but is it the KSS system ?

    as it is way more obvious over the earlier ultras

    Waz
    Might be, but if so, it is still a malfunction as turning or manipulation makes no difference

  5. #5
    don`t know if this helps, but Vman found that his cable adjuster was loose and the nut and washer were off the adjuster...
    just a thought...
    Glad you are ok Marc!

    whassup marc!

  6. #6
    Also check for cable routing from the handlebar to the actuator just under the glove compartment. It should be routed to the left side of the hull as you are sitting on the ski, away from any other cable/electical harness (most which are normally found on the right side).

    Another thought is checking the free play/tension of the cable which you can adjust by loosening the return pulley assembly from the deck (again just below the glove compartment area).

  7. #7
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    i had that problem but stayed at 6k for a period the cable returned right . i think it was that electronic throttle thing that misunderstood where that trottle was

  8. #8
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Quote Originally Posted by meangreenman View Post
    Also check for cable routing from the handlebar to the actuator just under the glove compartment. It should be routed to the left side of the hull as you are sitting on the ski, away from any other cable/electical harness (most which are normally found on the right side).

    Another thought is checking the free play/tension of the cable which you can adjust by loosening the return pulley assembly from the deck (again just below the glove compartment area).
    Agree! Check that, I moved a bit the cable to check some wiring, and ski will keep reving @3k!
    It took me almost 30 minutes to fix it!
    The potentiometer is very very picky

    Use your thump to push the detend the petentiometer and see if the RPM will drop.

  9. #9

    Join Date
    Feb 2006
    Location
    EAST COAST
    Posts
    1,168
    +1
    25
    Quote Originally Posted by elpeladodelsamba View Post
    i had that problem but stayed at 6k for a period the cable returned right . i think it was that electronic throttle thing that misunderstood where that trottle was
    WOW!!! Thats scary,,,makes me think of the run away toyota`s...I guess if the throttle would happen to fly wide open pulling the lanyard should shut it off.

  10. #10
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Quote Originally Posted by jeff007 View Post
    WOW!!! Thats scary,,,makes me think of the run away toyota`s...I guess if the throttle would happen to fly wide open pulling the lanyard should shut it off.
    Just use the handbrake when in trouble!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 300 trim issue
    By lasportsmn in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 08-26-2017, 03:23 AM
  2. ***ki Ultra 300 Left Steering Binding Issue***
    By WAVRAT in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 10-31-2016, 10:54 AM
  3. ULTRA 300 LX choked at full throttle
    By Ilano in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 08-30-2016, 10:30 PM
  4. Ultra 250 Throttle cable issue.
    By Skips313 in forum Kawasaki Tech Tips and Info
    Replies: 0
    Last Post: 12-06-2008, 09:43 AM
  5. Ultra 250 Throttle Cable Issue
    By Skips313 in forum Kawasaki Tech Tips and Info
    Replies: 0
    Last Post: 07-06-2007, 04:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •