Results 1 to 4 of 4
  1. #1
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29

    went muddin with my Seadoo Saturday - PISSED!

    Usually to dock it on the ramp I idle up to it and then just when the front hits I give it two quick blips of the throttle and she’s up and settled. Did this same thing Saturday but
    it wouldn’t go up. That’s when I turned around and realized I was shooting pure black mud
    Pissed! I backed down and headed back into the harbor and I could tell the thing wasn’t biting the water like it usually does. Took a while to clear out but after a few passes it did
    and I got my 60mph back (I know its low).
    So I tied a rope to the front loop and as soon as the front hit killed the engine and
    threw the rope to my brother in law and hopped out to help him pull it up. It was HAAARD.
    Took everything him and I had to get it up there and he isn’t a small dude , I’m about average. Guess I’m limited to an hour before and after dead low for now on, which sucks. Oh yea and try throwing a rope,
    killing the engine and jumping on the dock all at once like friggin Houdini

    My prop and wear ring has got to be crapped up even more now (original 07 - 190hrs)


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Make sure you flush it. The IC and exhaust are still open loop.

  3. #3
    boostedpgt's Avatar
    Join Date
    Jun 2011
    Location
    Jacksonville, Florida, United States
    Posts
    240
    Mine sucked up some mud on sat too. Sounded like a few shells or rocks too, but it was just at idle waiting to dock at the ramp. Flushed it as usual when I got home and there was a little bit of mud coming out for a few seconds.

  4. #4
    XDAILY's Avatar
    Join Date
    Jun 2011
    Location
    N. Wildwood
    Posts
    616
    +1
    29
    Yea I flushed mine as usual also.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help with my seadoo gsx limited
    By Lommi in forum 2-Stroke Performance
    Replies: 13
    Last Post: 04-25-2016, 03:57 PM
  2. problem with mys seadoo RXP-X 2008 ,starts and stalls.Wont stay running.
    By Bastiaan maarten Bok in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-01-2016, 10:53 PM
  3. need help with my 96 seadoo xp's im stumped!
    By brandon32689 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-28-2011, 07:21 PM
  4. Replies: 2
    Last Post: 02-14-2010, 11:45 AM
  5. What should I do to my triton trailer with the seadoos?
    By luckyc1423 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 11-05-2009, 08:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •