Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3

    swaped supercharger lowed rpms

    Question i swaped my s/c , and lost 450 rpms. the new one had 10 hrs or so on rebuild from jerry. I dont think its the charger, but with my old charger the machine would spin 7950 rpms and 70 mph on speedo ( i know its not 70). Know with newer charger its only spinning 7500 rpms? any idea? something i did, or in clutch? thanks guys


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Sounds like you have an impeller issue or something else internally with the engine is going bad. With the old charger, you were still 200 rpms off of what you needed it to be. You have an 04 yes? Is the update harness done. Might be a head gasket... Anything else done to the ski? Mod wise?

  3. #3
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    bone stock. how do you check for bost leak? what should these turn? head gasket no water in oil? but just switching sc. lost 450? whats the update harness? thanks tom

  4. #4
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    Quote Originally Posted by warner0308 View Post
    bone stock. how do you check for bost leak? what should these turn? head gasket no water in oil? but just switching sc. lost 450? whats the update harness? thanks tom
    knock sensor update harness, has your ski been hooked to buds since you swapped your sc if not check the slip on the charger

  5. #5
    b_dolla44's Avatar
    Join Date
    Apr 2008
    Location
    Noblesville, Indiana United States
    Posts
    1,165
    +1
    15
    Willing to bet its a boost leak....

  6. #6
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    It's not the charger. I can guarantee that. It came from me with 8 hrs and visit to Jerry before it shipped out.

  7. #7
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    If the super charger is the only change that you made, I would go back and remove and clean then reinstall your output side connection from super charger to inter cooler hose,tube, connectors which ever you have.

    Same would go for the intercooler output side if you had it removed for the SC install. If after you do this and do not see any improvement I would check the slip on the supercharger. But I would doubt that would be the issue on a recent rebuild on a stock charger. But you will need to eliminate it if the problem continues.

  8. #8
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    msrxp NEVER said it was the charger! just wondering if its the machine or something i did ? how do you check for boost leak? like vac. leak, spray with carb cleaner and see if rpms change? ive been thinking about this and it might have been gradually loseing rpms since i got it. i rode it twice got 7950 rpms but it was calm, like glass, and evrey other time since then its been choppey! and couldnt get a real reading. what does a bad wear ring do? more rpm or less or nether? thanks

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    I am betting that you have a boost leak. The hose that leaves the SC and goes to the TB might be loose or have a crack or tear. If so, I got one that I will send you.

  10. #10
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    can i spray it with anything? what does a wear ring do? when i got this machine it had sand in the opas, you could hear it when you turned. the other machine that came with it had sand and little rocks buy the pump. would that tear up a wear ring? and lose rpm?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 RXP Supercharged, Low RPM
    By fsts2k in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-07-2015, 07:58 PM
  2. 06 RXP Low RPM's, Supercharger, Low voltage...
    By dcvet in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-16-2008, 09:54 AM
  3. 06 rxp low rpm
    By rxpenpastu in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-21-2006, 02:25 PM
  4. Low RPM Issue
    By xenonx in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-19-2006, 03:19 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •