Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: mfd question

  1. #1

    mfd question

    my mfd now is working...i have a question, what is the red light blinking means??? and when i tried pressing the mode...it won't transfer to another modes??? does it need for the engine to run to fully operate the mfd???thnx


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    The flashing lamp usually means there is an issue, it's a warning lamp for low fuel/oil or overheat. I think the engine does need to run before the light will stop flashing but I'm not 100 percent sure.

  3. #3
    who knows about this craft??? sometimes the red light blinks, i think only when the engine is not running/??? im not sure.... i haven't tried the skii yet on the water with the mfd...maybe ill try tomorrow.. but if there is an issue why mfd is not displaying the issue???? i thot it will display something....not just a red light flashing

  4. #4
    who knows about this craft??? sometimes the red light blinks, i think only when the engine is not running/??? im not sure.... i haven't tried the skii yet on the water with the mfd...maybe ill try tomorrow.. but if there is an issue why mfd is not displaying the issue???? i thot it will display something....not just a red light flashing, and i also wonder why my volt is registering 15v?? when i check my battery with a multitester, it is only 12.5v..

  5. #5
    800AMSOIL4U's Avatar
    Join Date
    Aug 2006
    Location
    Morgan Hill, CA
    Posts
    5,024
    +1
    132
    It might be because the battery is low.

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Andy buddy start that sucker and let it run a minute, now what do you see?

  7. #7
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    yeah, start it up. I'm pretty sure mine flashes and reads wierd things until it has run for a few seconds.

  8. #8
    jcc011185's Avatar
    Join Date
    Sep 2006
    Location
    Kannapolis NC (north of Charlotte)
    Posts
    1,104
    Andy have you tried resetting your MFD? Sounds alot like what I got with mine before I reset it.. now it works perfectly.. sounds like it has logged an error and if you perform the reset procedure.. press the mode button for 10 seconds.. will display "CAL" or something of the like, then while still holding mode, press the set button for 10 additional seconds... the MFD should go through some random numbers while the second 10 seconds is lapsing... then it should automatically reset.. you could have one of three things causing the red light to blink (if it still does this after being reset).. it is either fuel, oil, or temp sensor.... your fuel float may be logged, oil float, or the temperature sensor could be throwing a code. This would cause the ski to run in limp mode, and display the blinking light. I, however, think you should try the reset procedure first as it may fix your problem entirely.

    Good luck!
    Jared

  9. #9

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    ya mine always flashes i dont know when i think when its not running , i wanna know why tha lil pitch thing doesnt work or seem 2 , i dont know

  10. #10
    okok. ill try when my plugs arrives, thnx

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 SLT750 MFD Question
    By way2much2do in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-16-2008, 09:20 PM
  2. Newbie (lurker) MFD question
    By PiP in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-30-2008, 06:44 PM
  3. 94SL MFD - Question about turning off
    By howie099 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-22-2007, 12:26 AM
  4. MFD question?
    By Polaris_Nut#1 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 07-08-2007, 09:55 PM
  5. MFD question, I might be dumb but.......
    By Tay71980 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 03-28-2007, 09:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •