Results 1 to 4 of 4
  1. #1

    97 SL900 No Spark

    I am working with the original ignition system not the update kit. I bought this ski not running with no spark. It came with a extra electrical box with parts and such. I put in a stator i got off of ebay and still no spark. Then i swapped the original cid back in and it worked great yesterday. The CDI in it when i got it is from an update kit i believe. Unfounrtaly while putting in the battery i believe the electrical box shorted out on the +. So now i am back to square one. No more spark. I didnt really see any burnt up wires going to the stator or inside of the box except for the yellow wire from the stator. It looked like it had be pinched in the box halfs and burnt when the box shorted. I checked all my grounds in the box and to the stator. OMHed all the coils on the stator they are good. I ohmed the hall effect sensors and i think they are good to. I swapped out the Voltage regulator and no difference so i think its good. I have decided either i burned up my new stator (don't know how to make sure) or i burned up the cdi box. I also swapped in a new coil pack but that didnt fix it. I hoped it was just a bad wire but i need to find a way to make sure if its the stator or the CDI or find where the problem is.


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    You can tell the old and new style stators apart by the windings.

    Post some pictures of your ignition parts / part #'s.

    The new style stuff will not work if mixed with old style stuff.

    The yellow wire is for the charging system, should not kill the spark- unless it is grounded now.

    Test the voltage on the red/purple wire going into the CDI.While cranking.

  3. #3
    Ok Well picked up an ultra 150 yesterday from a guy on cragislist and he also happened to have a whole updated ingiont kit. I bought the entire electrical box and the the stator for 200 bucks. I got it all in stalled this morning and still not spark. It will let out one tiny spark as soon as i left off the start switch but that its. It doesn't matter if i hold the start switch for 10 seconds or 30 seconds as soon as i let off the button it will spark once and its a weak spark. I had about 10.5 volts while cranking and 10.5v one the red and purple wire. I think i have a bad power wire or a bad ground some where. The update kit the whole box is grounded through the stator right? Where does the gray wire go in the update it? Its says Hall Effect Sensor ground instead of a second coil in the stator.

  4. #4
    Banned User
    Join Date
    Jun 2010
    Milwaukee WI
    I bet its a weak battery. try a new battery. Spark when you let go of the starter button is a tell tale sign of a battery thats not strong enough.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SL900 no spark
    By h400exrydr84 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 07-20-2011, 07:24 AM
  2. sl900 died - no spark
    By dannypz in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-14-2011, 10:56 AM
  3. SL900 spark problem
    By jennerus in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-03-2009, 09:51 PM
  4. SL900 - No Spark
    By rrated999 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-29-2008, 12:43 AM
  5. 96 sl900 no spark (what else?)
    By azcornman in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-12-2007, 03:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts