Results 1 to 3 of 3
  1. #1

    R12x won't tack out in water

    I have an issue with my ski.In the garage that thing runs great. In the water it will only tack out around 2.5k I have checked the plugs they look great. checked the turbo it spins freely with my fingers. the waste gate solenoid is working. I have not tested the map sensor does anyone know how?? thanks in advance I am ready to pull my hair out.

  2. #2
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Jax, Florida
    Put a new set of plugs from Advance Auto Parts 9.99 each and get a can of Sea Foam too. You can't tell by looking at them.

  3. #3


    ok I will do this. do you by chance know how to test the map sensor? I would like to go ahead and test it. I have sea foam in it now tring to run it threw.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in the engine, and now it won't start...
    By compact in forum Kawasaki PWC Performance (4-stroke)
    Replies: 28
    Last Post: 09-21-2011, 10:41 AM
  2. Tiny Tack RPM gauge
    By 1400gprmike in forum Yamaha Classifieds
    Replies: 3
    Last Post: 04-28-2009, 02:58 PM
  3. r12x internal water leaking/ after ski wasn't winterized
    By Dirty Sanchez in forum Honda Open Discussion
    Replies: 2
    Last Post: 07-10-2008, 01:54 PM
  4. wtb 85 nozel and tiny tack
    By seadoolover in forum Yamaha Classifieds
    Replies: 2
    Last Post: 06-25-2008, 04:46 PM
  5. Under a Tack
    By elebouef in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 12-26-2005, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts