Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2007
    Location
    western ky
    Posts
    65

    sl 1050 wont open up?

    sl 1050 cranks up fine then just putts around wont open up .cleaned carbs and changed fuel lines no help what next any ideas.


  2. #2
    rlharrison60's Avatar
    Join Date
    Aug 2007
    Location
    Orange, Texas
    Posts
    1,091
    +1
    1
    Is it firing on all three cylinders? Did you check to see if there was water in the filter? Compression?

  3. #3
    rlharrison60's Avatar
    Join Date
    Aug 2007
    Location
    Orange, Texas
    Posts
    1,091
    +1
    1
    Also, First start off with a fresh battery.

  4. #4
    i was running mine yesterday and it is doing the same !! what the hasck is it ?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by cas View Post
    i was running mine yesterday and it is doing the same !! what the hasck is it ?
    Welcome

    May not be the same problem cause, even if the symptoms are similar.

    Start with the basics; compression, carb rebuild, file system, correct spark plugs...

    1996-1999 red engines have an Ignition Update Kit available from Polaris, if it turns out that ignition is not working properly.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Check to see if anything is in the water intake.

    Look and see if the driveshaft is spinning as fast as the motor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris SL 650 Won't Open Up - Please Help Me!
    By vicbomb5 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 08-10-2015, 01:12 PM
  2. SL 1050 wont start
    By twistedpower in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-23-2013, 10:15 PM
  3. 94 650 SL wont rev up!
    By guitar jeff in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 06-25-2010, 03:47 PM
  4. Opening up the Closed Loop
    By Shibby1485 in forum 4-Tec Performance
    Replies: 36
    Last Post: 11-04-2006, 07:17 PM
  5. Can't Find my SPEED? MY RXP wont wake up!
    By Water4fire in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-12-2005, 07:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •