Results 1 to 6 of 6
  1. #1

    Join Date
    Jun 2008
    Location
    Winnipeg, Manitoba canada
    Posts
    77

    Problems with my 2001 Pro 1200

    Hey Guys,

    Took my boat out for the first time since i bought it. Finially found the ski I was looking for Its a 2001 Pro 1200 with 32 hours on it. Mint Shape bought off the first owner. Ski has 32.8 Hours on it. Put a new set of plugs in and and went over everything before i hit the water. Fired right up, started cruising around keeping around 4500 rpms. let the ski warm up abit and then started riding it. about 4 minutes into the ride it wouldn't rev pass 4000 rpms. Limpt back to the shore and turned off the boat. when I opened the seat smoke was coming out. Water box was so hot that it had heated up the exit tube. you could fry an egg on it. so I loaded it on the trailer and made sure i didn't suck up any sea weed. everything looked good. put it back in the water, fired it up could feel water in the exhaust hoes. when for a small 2 minute ride lots of power but came back in and the water box was boiling again. put back on the trailer and took it back to the cabin. Large exit tube hose and melted almost closed. melted the small hose between the water box and exhaust manifold. took the exhaust manifold off and water box out. everything looked okay with nothing trapping water. There is a small pinkish red pop vavle going from the top of the exhaust manifold to the bottom that the ball got stuck in the opening and wouldn't let anything og through. What is this vavle for???? do i need to keep it. For what i can see the water from the engine fills the top of the exhaust manifold then water goes through that hose which fills the bottom part and then that water goes through the water box? is this correct


    You guys all know your stuff on this forum this is why I am here. Thank you in advance if you can help.

    P.s for all the guys that told me to buy a pro 1200 after i sold my 785 Pro. thank you. Only got to drive it for a few minutes but cannot wait to get back on it
    Click image for larger version. 

Name:	30716me_20.jpg 
Views:	60 
Size:	90.9 KB 
ID:	244718


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    that is a Jetworx valve it helps give you alittle more bottom end you can get a better ball for it so it doesn't fall back in again .If you have it out already just put alttle grease on it and put it back in and it should be good for the season ,you need to check them from time to time

  3. #3

    Join Date
    Jun 2008
    Location
    Winnipeg, Manitoba canada
    Posts
    77
    Thank You 785 LUGS

    Would the ball getting stuck,stop water from flowing into the water box? would it be possible this would cause the engine to bog out????

  4. #4

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    yep it helps cool the stinger before it hit's the waterbox

  5. #5

    Join Date
    Jun 2008
    Location
    Winnipeg, Manitoba canada
    Posts
    77
    LUGS,

    In your opinion Do I want to go with an adjustable or non adjustable Jetworx valve. also do you know if the gasket between the manifold and exhaust pipe can be reused or do they have to be replaced everytime they come apart.

    Thanks buddy

  6. #6

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    stay with the stock valve and contact derwood on here he has a bunch of the upgraded balls for them also if the gasket looks good just put a thin coat of silicne on it and put it back together

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My 2001 Pro 1200
    By Mr. Matrix in forum Polaris Projects
    Replies: 274
    Last Post: 08-01-2015, 05:14 PM
  2. Problem with my 2001 Virage 700 start/stop button
    By Old Stan in forum Polaris Open Discussion
    Replies: 10
    Last Post: 03-04-2015, 09:43 AM
  3. WTB - Parts looking for a factory polaris cover for my 97 pro 785 and 2001 pro 1200
    By 1998PRO785HO in forum Polaris Classifieds
    Replies: 0
    Last Post: 04-23-2012, 01:53 AM
  4. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •