Results 1 to 6 of 6
  1. #1
    T-DUB's Avatar
    Join Date
    May 2009
    Location
    LEHIGH ACRES, FLORIDA
    Posts
    211

    Need help with my 02 gtx 4-tec

    Gauge cluster on my 02 sea-doo gtx 4-tec(155hp) does not work at all meaning the speedometer and tach do not move at all and the gauge itself does not illuminate the info that it is suppose to...any ideas or things to check? I would hate to buy a gauge and not have that be the problem...maybe there is a trick that one of you know that i don't know...please help


  2. #2
    have checked the fuses on the mpem??????

  3. #3
    T-DUB's Avatar
    Join Date
    May 2009
    Location
    LEHIGH ACRES, FLORIDA
    Posts
    211
    good point and I did do that a week ago and they were all intact

  4. #4
    im looking for a 2002 GTX 4Tec gauge cluster. Anyone have any idea where I can get my hands on two for really sweet deal? Prices in store are outrages.

  5. #5
    PM 4tec's Avatar
    Join Date
    Nov 2009
    Location
    oHIo
    Posts
    28
    +1
    2

    Replace it with a NEWER gauge

    Quote Originally Posted by djdvrdoc View Post
    im looking for a 2002 GTX 4Tec gauge cluster. Anyone have any idea where I can get my hands on two for really sweet deal? Prices in store are outrages.


    I fryed my 2002 Gauge with the wrong battery replacement....Got a 2003 or 2004 Gauge and now my ski has digital RPM read out and everythingworks fine now with new battery

  6. #6
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    After you check everything else maybe try this;

    http://www.greenhulk.net/forums/showthread.php?t=172255

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with my GP1200!
    By MTAINFLA in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-28-2008, 02:13 PM
  2. i need help with a 98 gtx ltd, driving me crazy
    By kctaylor in forum 2-Stroke Performance
    Replies: 5
    Last Post: 03-20-2008, 07:51 AM
  3. Need help with my C180
    By Atlantis in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 09-12-2007, 08:46 PM
  4. Need help with my 1050 mph
    By 1FASTXC in forum Polaris Open Discussion
    Replies: 32
    Last Post: 06-09-2007, 02:05 PM
  5. Need Help with my STLX 1050
    By Johnquest in forum Polaris Open Discussion
    Replies: 18
    Last Post: 03-15-2007, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •