Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Strange Results

  1. #1
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2

    Strange Results

    Full Riva Stage 2 including the 15/20 prop:

    Stock ECU: 72 mph at 7750 RPM

    RR ECU: 69.8 at 7600 RPM

    Both ECU's spun the prop out of the hole. Out of the hole, RPMs would shoot to 8200 (stock ECU) and 8350 (RR ECU), then settle into the 7600-7750 range.

    Pro Series opas blockoffs are awesome and thru hull exhaust sounds mean. Now if I could just get my RPMs up, things would be great.


  2. #2
    R.I.P. 11's Avatar
    Join Date
    Apr 2005
    Location
    Santa Monika, People's Republik of Kalifornia...
    Posts
    1,571
    +1
    1

    Re: Strange Results

    Quote Originally Posted by Franko
    Now if I could just get my RPMs up, things would be great.
    As long as that's the only thing that doesn't get up.

    Sorry that was lame, I know.

    Anyways I don't remember where I got this from but I think wiring harnesses on RXPs changed a couple times, maybe you have the wrong harness or miss an adaptor.

  3. #3
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,278
    +1
    2
    Those are very similar results that my riding buds are experiencing!

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,424
    +1
    176
    maybe open up the venturi a little for some more rpms..might be worth a shot...It worked on mine

  5. #5
    R.I.P. 11's Avatar
    Join Date
    Apr 2005
    Location
    Santa Monika, People's Republik of Kalifornia...
    Posts
    1,571
    +1
    1
    The fact Frank gets more RPMs from stock compared to RR means he has electrical/compatibility problems.

    Or maybe the Riva stage 2 and Rotax ECU aren't meant to work together.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    Well, i have heard of someone using the RR ECU with the Riva Stage 2 with positive results.

    I think i would like to back to back test Franks ECU with mine.

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    i'm not even so sure it's the ECU that's the problems.... it's like each ski is wired completely different and if u get a lucky RXP it will accept the RR ECU..... this compatibility issue just doens't make sense in my mind no matter which way i look at it.

  8. #8

    Join Date
    Jun 2005
    Location
    Cayman Islands
    Posts
    705
    I have similar #'s

    Full Riva Stage 2 with 14/19 8100rpm all day, ?? MPH (No GPS)

    Riva Stage 2 with 15/20R 7750rpm max 70.6mph (GPS) 2 bars from full (gas)

    Stock ECU, RR Thermostat.
    Temps mid 80's

    Riva Stage 1 8050rpm GPS 71.5mph 1/2 tank of gas
    Rider 240lbs 6'4"

  9. #9

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    Frank, Get a Llama, they are fast @ about 40mph, cut and fertilize your lawn at the same time too!!

    http://www.mountlehmanllamas.com/llama-running1.MOV

    TLR

  10. #10

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    sounds like the OEM ECU is the winner!

    how about adjusting the throttle cable,etc??

    borrow someones venturi thats been opened up just a tad to test with.

    and maybe borrow a 14/19 to test also.

    I read somewhere in the wiring harness there are diodes that need to be disabled or something? for that RR ECU to work right??

    Tim

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 69.8 mph stocker with strange results modified (x charger)
    By engineermike in forum 4-Tec Performance
    Replies: 7
    Last Post: 11-23-2008, 05:59 PM
  2. Franks 80+ mph videos and results from Saturday
    By Enufpwr in forum 4-Tec Performance
    Replies: 16
    Last Post: 09-11-2008, 01:54 PM
  3. Today's test results 5/9/05
    By Jrsrxp in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-10-2005, 01:32 PM
  4. weekend results I'm happy
    By watermedic in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-09-2005, 06:01 PM
  5. My Mods and test results
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-05-2005, 07:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •