Results 1 to 6 of 6
  1. #1

    1996 SLT terminal board help!

    Anybody have a picture of where all the wires are supposed to go, i stupidly pulled out the board cause there was some major corrosion. I cleaned everything and started to put wires back as labeled on the board, i seem to have extra wires, green ones, and a orange bridge. I bought the clymer manual hoping there would be a picture of the board and where everything went, but it didnt have it. If anybody could help me out that would be great.

    Last question is, one of the terminals corroded and pulled out, can i just electrical tape it so it doesnt interfere with the other connections?


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    The board has abbreviations on it for the color coded wires. Just follow the colors.

    If your board was corroded, you may want to get a new one on the way. Just in case that one gives you probs. They're not expensive at all.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,572
    +1
    1,272
    Welcome

    Orange bridge?

    Post a few clear photos of what you have there.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Sometimes they will have an orange wire with fuse normally that goes to the "spare" terminal on the board. Usually in cases where a bilge pump or external tachometer was installed

  5. #5

    more problems

    Looks like the the terminal board was just a start to my problems. I had a plug that looks like it was welded (pre-ignition most likely) probably due to my corroded terminal board. And I took off the cyclender head to find my middle piston very F'd up. I took out the pipe and header to get at the cyclinder, luckly very minimal scoring. I have a new piston, rings, gaskets etc on the way, plus a new terminal board. Once i get the new board I will post the wires i am confused with, i have 5 lime green wires that i cant figure out where they go, I dont know if they were once green/white or just green. I will have some pics very soon so you all can take a look.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Please post some pics. There shouldn't be any lime green wires.

    Green with white stripe = trim

    Green with red stripe for elec stator and CDI

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SLTX Terminal Board
    By ssmi291 in forum Polaris Open Discussion
    Replies: 25
    Last Post: 08-02-2013, 11:21 AM
  2. 1996 slt help
    By Coltsfan in forum Polaris Open Discussion
    Replies: 16
    Last Post: 05-22-2012, 05:24 PM
  3. 1996 SLT 780 Top End on 1995 SL750 help
    By mikefromedson in forum Polaris Projects
    Replies: 3
    Last Post: 09-29-2011, 09:17 PM
  4. My 1996 SLT 780 won't start, just clicking sound please help!!
    By smitty564 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-28-2011, 08:35 AM
  5. Help advise-1996 SLT 700
    By polaris slt700-darn in forum Polaris PWC Performance
    Replies: 1
    Last Post: 07-28-2009, 10:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •