Results 1 to 4 of 4
  1. #1

    multi function gauge?

    on my 94 slt the multi function gauge doesnt work. no light or anything. when i bought it the guy said it blew a fuse. replaced fuse and it still doesn't work. any ideas would be great.

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Check voltage at the disconnect.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    See the MFD section from my signature links.

    Did the replacement fuse blow? If yes then the MFD may have shorted internally, in which case it is rarely repairable.

  4. #4

    Polaris MFD reset & repair info

    The Polaris PWC knowledge forum has a very helpful and detail information on the Polaris MFD


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Multi Function Cluster
    By gofish34 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 01-11-2011, 12:03 AM
  2. Multi Function Display
    By soupson in forum Polaris PWC Performance
    Replies: 6
    Last Post: 06-20-2010, 08:35 PM
  3. Multi Function Gauges
    By mxl16 in forum 4-Tec Performance
    Replies: 15
    Last Post: 01-06-2010, 05:17 PM
  4. FS:Multi function guages from 96 XP (2)
    By Seadooracer9 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-26-2008, 05:40 PM
  5. 95 vs 96 multi function display
    By 95yami701 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-21-2008, 06:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts