Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Angry emergency stuck in the water!!! please help with 05 rxp !

    i went up on a big wave and landed hard.. when i landed the ski turned off and now it wont start! the screen goes off everytime i press the start button and it comes back up in a little while and it just sais "seadoo" . the ski was riding perfect all day until this one wave! i have a feeling its a loose cable but i checked all the fuses one by one and it is not that. well i checked the fuses in front of the gas tank . are there more fuses?


  2. #2
    look for loose connection

  3. #3
    i did i unpluged and repluged all electrical fittings in my sight...

  4. #4
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,693
    +1
    40
    It is the battery! Change it and check it out!

  5. #5
    i dont think its the battery its been starting right up everyday since i bought it a week ago .. plus its been riding today perfect until that freaking wave came now it dosnt start

  6. #6
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,693
    +1
    40
    Quote Originally Posted by bksbigboy69 View Post
    i dont think its the battery its been starting right up everyday since i bought it a week ago .. plus its been riding today perfect until that freaking wave came now it dosnt start
    Thats correct,when you did that wave jump you broke it!I had the same issue a couple years ago when the ski did a jump and then died!The customer swim about 30mins to take the ski to the beach.Then he get the ski to my shop and I just bolt a new battery and all was good!

  7. #7
    will try thank you

  8. #8
    you were right! the battery had cracked the plates inside and lost all the acid. thud it had 9.4volts only and 0cac it was completely bad. problem was that i just bought this ski last week and this was the first real ride i went for more than 1 hour. the previous owner obviously did no maitnance on it because he never changed the battery it was original 05 battery . when i bought the ski i redid the complete pump bearings , oil seals, wear ring. etc. i also just noticed today that its an 05 but it obviously has a problem with the knock sensor because it only gets up to 7700 rpm and 64 mph gps. besides that the ski runs perfect. im going to take out the supercharger this weekend to double check for the metal clutch washers.

  9. #9
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by mitsakosgt View Post
    It is the battery! Change it and check it out!
    Hello mitsakosgt, Were do you guys ride i am going to be in Petropolis out side of Athens in a couple weeks.

  10. #10
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    Hello mitsakosgt, Were do you guys ride i am going to be in Petropolis out side of Athens in a couple weeks.
    Take mitsakosgt my waterbox to him as he is interested in it lol, It'd save me some shipping cost lol

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 05-28-2013, 09:24 AM
  2. Replies: 4
    Last Post: 07-09-2011, 06:50 PM
  3. problems again please help would like to get in the water
    By freemandino25 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-12-2010, 08:24 PM
  4. Need help with 05 RXP lines?
    By bryanw80 in forum 4-Tec Performance
    Replies: 9
    Last Post: 12-17-2009, 11:21 PM
  5. Barely moving in the water! Need Help!!!
    By DKFox in forum 2-Stroke Performance
    Replies: 12
    Last Post: 08-20-2009, 09:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •