Results 1 to 4 of 4
  1. #1

    question on SL 750

    In the process, literally, of replacing the possible bad stator on 1994 SL 750, after pulling flywheel, noticed some oil in bottom of the stator cover. Is this normal, should there be some oil?

    thanks
    monkeyass


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Most likely means your front crank seal is leaking.

  3. #3
    would the bad seal, leaking oil into the stator casing... caused the stator to go bad ?, thus causing the no spark issue.....

    my how the trail goes deep...

  4. #4
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    It's possible. On 750's one of the primary causes of stator death is a missing plastic cover for the battery. This allows the Ebox to short to the positive side of the battery and fry the stator. But, there are other reasons that can cause it as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. boring q's on sl 750
    By Boatski in forum Polaris Open Discussion
    Replies: 9
    Last Post: 04-29-2010, 04:20 PM
  2. riding 2 people on SL 750
    By JimboJames in forum Polaris Open Discussion
    Replies: 10
    Last Post: 08-17-2009, 04:36 PM
  3. ignition question on 1995 750 slt
    By zakatak in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-03-2009, 05:50 PM
  4. Loss of Power on SL 750
    By phixer0364 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-02-2008, 10:33 PM
  5. Help with new pistons on SL 750
    By jmule98 in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 08-16-2007, 10:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •