Results 1 to 4 of 4
  1. #1

    question on SL 750

    In the process, literally, of replacing the possible bad stator on 1994 SL 750, after pulling flywheel, noticed some oil in bottom of the stator cover. Is this normal, should there be some oil?


  2. #2
    Banned User
    Join Date
    Jun 2010
    Milwaukee WI
    Most likely means your front crank seal is leaking.

  3. #3
    would the bad seal, leaking oil into the stator casing... caused the stator to go bad ?, thus causing the no spark issue.....

    my how the trail goes deep...

  4. #4
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Mt. Zion Illinois
    It's possible. On 750's one of the primary causes of stator death is a missing plastic cover for the battery. This allows the Ebox to short to the positive side of the battery and fry the stator. But, there are other reasons that can cause it as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 750 SL Question
    By jparks in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-16-2011, 07:04 AM
  2. 94 kawi 750 sx question
    By gee10 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 05-30-2011, 11:00 PM
  3. SL 750 Question
    By rareform in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 01-26-2011, 11:23 PM
  4. 750 Carb question
    By polaris 750SL in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-27-2008, 01:13 AM
  5. 94 750 sl question
    By minersny in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-13-2007, 06:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts