Results 1 to 5 of 5

Thread: 2001 Genesis I

  1. #1

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109

    2001 Genesis I

    I bought this machine 2 years ago. It was not running when I purchased it as a non runner. I ended up replacing a functioning Emm and injectors from another machine. Last year it ran great. This year first time taking it out, same as before. Seems to want to go but then doesn't. Max Rpm 5200, speed max 40. Half throttle only otherwise it kinda goes into limp mode. Maybe TPS or send it off to DFI.....your thoughts guys!!


  2. #2
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Did you put some stabil in the fuel when you were storing it over the winter? I assume since it ran good last year that you have good compression? Have you checked the fuel pressure? TPS's can go bad on these along with a few other things but if it was running good last year I would first look at the fuel if you havent previously. I dont think its in a "limp mode" at 5200 RPM but I could be wrong. Any warnings on the MFD?

  3. #3

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    When I winterized it I put stabilizer in the fuel, filled the tank with premium, filled the oil reservoir with the same synthetic oil I have always used. It was running perfectly the day I put it away. Stored the battery inside. It started immediately, idles perfectly, fires instantly....it gets hard throttle then just dies unless I reduce the throttle I can get it to plane slowly but can't go past 1/2 throttle or it wants to die out..

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Check injector voltage, although I expect it is fine. Should be 45 volts on white/red wires with all injectors plugged in and engine running.

    Also check fuel pressure. Should be over 20 PSI.

    My expectation is that the TPS needs replacement. Not that expensive, and it is always good to have a spare TPS on hand anyways.

  5. #5

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    I changed the TPS last year but it was from an older machine so I shall get a new one...any sites for that part

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 genesis i heating problems
    By bruddahdave in forum Polaris Open Discussion
    Replies: 9
    Last Post: 03-08-2008, 08:47 PM
  2. 2001 Genesis no-spark, no-fuel
    By chev-hell in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-24-2007, 04:50 PM
  3. Thinking of buying this 2001 Genesis - Opinions or comments?
    By K447 in forum Polaris Open Discussion
    Replies: 15
    Last Post: 09-12-2007, 05:16 PM
  4. 2001 Genesis cutting out
    By go2lkg in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-21-2007, 06:11 PM
  5. friends 2001 genesis
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-13-2007, 04:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •