Results 1 to 8 of 8
  1. #1
    svtnos's Avatar
    Join Date
    Aug 2007
    Location
    Almont MI
    Posts
    316
    +1
    1

    is there a good reason they dont open?

    Just wondering why my rave valves open sometimes and others dont open at all.. i cleaned the snot out of them and i check them all the time after a ride.. they are free moving and not completely gummed up.. yet they barely open half the time.. the motor just hangs out at 6500rpm all day long.. once in awhile the raves actually open and the motor sings to 7000rpm.

    is there a reason they dont always open when they are supposed too ?


  2. #2
    There are a couple of possibilities

    O-Rings (Leaking)
    Bellows (Leaking)
    Caps (Cracked and Leaking)
    RAVE Solaniod
    Check Valve from the crankcase
    Possibly the springs inside the valve

    One used ski I bought used actually had the top springs missing

    They make rebuild kits for them, might give them a shot.

  3. #3
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Yea,check the little "oneway" check valve from the crankcase

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    +1....also have you gone through the fuel system and the carbs? just checking.

  5. #5
    svtnos's Avatar
    Join Date
    Aug 2007
    Location
    Almont MI
    Posts
    316
    +1
    1
    Quote Originally Posted by sea-one View Post
    Yea,check the little "oneway" check valve from the crankcase
    i tried following the line from/to the solenoid and it disappears some where underneath the engine..??? where is this checkvalve??

    Quote Originally Posted by airbornexp View Post
    +1....also have you gone through the fuel system and the carbs? just checking.
    yes, right before i cleaned the raves the first time i pulled the carbs cleaned them, ran new fuel line, cleaned selector valve, and main inline fuel filter.

  6. #6
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Its on the PTO end under the carbs behind the starter, its there. its a PITA to get to unless the carbs are off.

  7. #7
    try to ride it and then cavitate the prop to unload the engine, hop the ski lean it to one side hit a big wake. anything to get the intake out of the water to let the engine rev. see if it takes off and holds rpm. only getting to 6500 rpm and holding there seems another issue other than rave valves. what prop, is water injection in the pipe working? ect. also what motor is it 787 or 951? asuming 951 since you mentioned rave valve solenoid. could do the drill modification and make them work like the 800 rave valves off exhaust gas pressure instead of crank case pressure.

  8. #8
    svtnos's Avatar
    Join Date
    Aug 2007
    Location
    Almont MI
    Posts
    316
    +1
    1
    Quote Originally Posted by slociviccoupe View Post
    try to ride it and then cavitate the prop to unload the engine, hop the ski lean it to one side hit a big wake. anything to get the intake out of the water to let the engine rev. see if it takes off and holds rpm. only getting to 6500 rpm and holding there seems another issue other than rave valves. what prop, is water injection in the pipe working? ect. also what motor is it 787 or 951? asuming 951 since you mentioned rave valve solenoid. could do the drill modification and make them work like the 800 rave valves off exhaust gas pressure instead of crank case pressure.
    from what i have read and played with it is def in the raves.. its just being super sensitive like a woman.. im seriously shooting for swapping the raves from my 800 to the 951 and seeing how it runs this weekend.. my 800 has run and hit top rpm and mph for the past 8 years consistantly with/o ever pulling the carbs and raves.. this year was thefirst time either of them have been off .. soo we shall see.. if the 800 raves work then i will either be A. drilling out the 951 raves and or B. buying a set of 800 rave housings to use with the actuall951 rave valves..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is there a reason my Yamaha skiis dont want to start quickly after sitting????
    By mwinschel in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 02-27-2016, 04:22 AM
  2. 5 good reason WHY a aftermarket ECU is better the reflash. No Mods to delete or close
    By RichieFZR in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 05-17-2011, 08:56 PM
  3. Replies: 0
    Last Post: 05-22-2010, 06:10 PM
  4. A Good Reason to Like Delaware
    By Pettee in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-04-2006, 09:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •