Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174

    Unhappy Need any/all feedback on recent mods to 2011 RXT-X 260 (Canadian Model)

    I recently added the R&D intake grate, Riva override module and Solas 15/22 prop (which I sent to Erik at Speedfreeks to repitch/set back mod).

    Before the mods I could run with a full tank of fuel and hit (and sustain) speeds of 69 sometimes 70 if the conditions were ideal.

    After the mods, I am seeing the same readings. I do see a better hole shot and feel the machine has better handling but should I not be seeing an increase on the speedo? I have watched the rev's and although the conditions were fairly rough when I tested it, I never saw the revs get to 8000.

    I have heard that the speedo might not get past 70-71 but actual speeds are higher and was told to test with handheld gps to find out for sure. I thought with the model I have, it has a gps speedo?

    I am disappointed that the info I had on the override didn't state that the selection of SPORT MODE is done before starting. IT DOES NOT START UP IN SPORT MODE UNLESS YOU CYCLE THROUGH BEFORE YOU TURN IT ON. That is just as much a pain in the @ss as doing AFTER you start it. Let's get that fixed so you can just sit down, plug in yellow key and go into sport mode DIRECTLY.

    So far, I am not impressed with the module, as my speedo has not changed and as far as I know I am not going any faster. Not to mention the sport mode process.

    I am in fact impresses with the services of Speedfreeks, the prop seems to give me a better launch and the turn around time was excellent.

    Maybe I need to do more testing, but ANY feedback would be great.

    Thanks


  2. #2
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    There's many discussions about activating sport mode when engine is off. Power ski up, press and hold mode button until it's beeps and prompts you to activate sport mode, activate Sport mode. Start ski, enjoy sport mode.

    By doing the above, this will let you know your module is functioning the way it should. If not, then that should explain why your not seeing over 70 on the speedo. Theres roughly a 1.5-2 number difference between speed and hand held gps.

  3. #3

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174
    When testing last night, I did cycle through and select the sport mode before starting. So the module IS working as far as I know. So next question...will the speed go past the 70 mph? Seems like a lot invested for very minimal gains? Maybe I was fooled by all the research. 3mph for this, 2 for that etc. I was truly expecting a 5 mph gain ON THE SPEEDO (that is supposed to be gps as well).

  4. #4
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by Urwheelman View Post
    When testing last night, I did cycle through and select the sport mode before starting. So the module IS working as far as I know. So next question...will the speed go past the 70 mph? Seems like a lot invested for very minimal gains? Maybe I was fooled by all the research. 3mph for this, 2 for that etc. I was truly expecting a 5 mph gain ON THE SPEEDO (that is supposed to be gps as well).
    Try not cycling through. Try to steps I mentioned above. This will be clear cut of the module is installed correctly. The speedo will never match a handheld gps. Can't answer why, but seadoo may have an answer idk.

    Yes your speedo will go above 70 and you'll will see a gain but only if the module is installed correctly.

    Who did the installation?

  5. #5

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174
    Just to be clear lol, I did the sport mode selection BEFORE I put the key on and started it. SO when it started it was already in sport mode. Is that what you are saying will let me know if the module is installed correctly? I had the local sea doo dealer install it for me. I did see 71 flicker on the speedo last night but 70 was the max i could get. I was getting that before all the mods were installed. thanks for the help Scott (I joined your eastcoastpwc as well)

  6. #6
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455


    Stuckmoto was nice enough to make a video

  7. #7

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174
    I will have to try that method when I get home, see if it does the same thing. Crazy when you spend that kind of money to get some results and get let down lol.

  8. #8

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174
    Anyone else's speedo staying at 70? Heard that some will not exceed 70 mph no matter what speed you are going?

  9. #9
    Quote Originally Posted by Urwheelman View Post
    Anyone else's speedo staying at 70? Heard that some will not exceed 70 mph no matter what speed you are going?
    Not sure if this could be a problem but just a thought. make sure you have the Override Module for the 2011 Ski as there is a 2010 module which looks the same

  10. #10

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174
    Thanks MARK82, I should be seeing the same results as you, the mods are almost exactly the same! (how did you fill the ride plate holes?)

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Not sure on what to do with this? 2011 RXT iS 260
    By csrMark in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-26-2014, 06:14 PM
  2. Best location to install a bilge pump on 2011 RXT-X 260 RS????
    By jumpman in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 02-15-2014, 01:00 PM
  3. Dilemma on how to flush my 2011 RXT-X 260 RS
    By jumpman in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 02-14-2014, 07:17 AM
  4. Replies: 16
    Last Post: 08-07-2013, 03:54 PM
  5. Update After Some Quick Mods to '06 RXT
    By WAMason in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-04-2006, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •