Results 1 to 9 of 9

Thread: help wear ring

  1. #1
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3

    help wear ring

    alright first let me say, sorry for all the dumb questions, But i have a nother one my 2004 rxp. it has a white wear ring in it and it looks like theres NO clearence!! you can see where the prop is scraping the ring, is that correct? its all the way around. also when you look up in the grate theres a rubber bushing? that looks like it slid a inch up the shaft. does this sound like my 7500 rpm prob. thanks guys tom


  2. #2
    Michigan sn-95's Avatar
    Join Date
    Sep 2010
    Location
    Hamilton MI
    Posts
    734
    +1
    32
    Quote Originally Posted by warner0308 View Post
    alright first let me say, sorry for all the dumb questions, But i have a nother one my 2004 rxp. it has a white wear ring in it and it looks like theres NO clearence!! you can see where the prop is scraping the ring, is that correct? its all the way around. also when you look up in the grate theres a rubber bushing? that looks like it slid a inch up the shaft. does this sound like my 7500 rpm prob. thanks guys tom
    Yes, it does sound normal. Minimal clearance is good. The rubber piece should be against the prop. It wouldn't hurt to post a pic so we can see exactly what you're seeing.

  3. #3

    Join Date
    Feb 2011
    Location
    Canton, GA
    Posts
    103
    Double check the new part number to make sure u got the right one.the new ones are grayish or blue dont remember..that bllack bushing ur talking about is not a bushing at all goes on the end of ur prop to keep water out from were shaft and prop connect.i would replace it with the speedfreeks one

  4. #4
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    You should have almost no clearance. Start the ski in the water for the first time. DO NOT START the ski on the hose. IN THE WATER FIRST.

  5. #5
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    this isnt a new ring. its the stock one from 2004,how do you know when you need a new one?

  6. #6
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Chances are you need one after 8 years. Cavitation on hole shot. Top end loss and rpm loss. total loss in performance.

  7. #7
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Cone sliding up shaft will definately lose rpm's

  8. #8
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Are you getting any vibrations? Have you checked the pump bearings? Have you pulled the pump? Have you checked the pump grease? Has anything strange happened lately?

  9. #9
    Less clearance the better

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 09-20-2007, 03:39 PM
  2. Replies: 13
    Last Post: 09-01-2007, 11:20 PM
  3. Need a new wear ring help a brotha out! ;o)
    By RustySeaRustyDoo in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 08-21-2007, 10:38 PM
  4. Need Help: Replacing Wear Ring on 97 GTX
    By MPower in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-31-2007, 09:27 PM
  5. Wear ring ? need help fast!!!!
    By NeverEndn in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-08-2006, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •