Results 1 to 5 of 5
  1. #1

    slt 780 limp mode

    When I try to go wide open it just sputters, the mfd displays low fuel, is there a grey wire somewhere I can disconnect. I'm new to this jet ski thing, would appreciate any help


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the Hulk.

    Removing the grey wire is just a temporary solution, you really should fix the problem.

    Most likely the fuel float is bad. You can get one from john Zigler or Jay at Sharp's Marine for around $30

    The grey wire is inside the elec box. You can disconnect it from the circuit board as a temporary fix. It also prevents engine damage in case of low oil or an overheat situation.

  3. #3
    sorry to sound like an idiot but im a diesel mechanic trying to due a favor for a friend, so this is the first ski i've worked on, where is the electrical box, is it where the spark plug wires go in and the grey wire is inside it? Could I also take the red one from the fuel tank and tie it in with the blue from the oil? Thanks for the help

  4. #4
    My buddy actually had a new sender with float, installed, runs great, thanks again

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Sweet!!! And it's the proper fix.


    Yes the elec box has the plug wires coming out of it. And no, you can't just tie in the oil sender wire.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SLT 780 limp mode @ around 4000 RPM
    By polarisman89 in forum Polaris Projects
    Replies: 2
    Last Post: 07-01-2016, 07:56 PM
  2. 1996 SLT 780 Limp mode no lights. Please Help!
    By Mile High Racing in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-05-2015, 11:14 PM
  3. 97 SLT 780 limp mode??
    By john zigler in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-21-2011, 08:58 AM
  4. polaris slt 780 limp mode
    By rfbob in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-24-2009, 09:01 AM
  5. input please. '96 slt 780 limp mode...
    By 19svt97 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-26-2008, 11:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •