Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jan 2011
    Location
    Amityville, New York, United States
    Posts
    118

    08 rxt taking in waterrrrrrr

    Hey guys my 08 rxt is taking on water I went for a 20 min ride when I pulled it out the ski had water in it it was a lake out so I kno it wasn't coming thru the front hatch and the water was steaming hot I don't know If it was cause by throttling it up on the beach but after I beached it it started it's not the seal I had that looked at any advice?


  2. #2
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    If the water in the hull was steaming hot then you have a leak in the open cooling system either exhaust of intercooler but I would say exhaust. Run the ski on the hose and look for leaks.

    Failing that check for a cracked/split intake tunnel

  3. #3
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    how much water?

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Kaybat View Post
    how much water?
    +1 Just because the water was hot does not mean it came from the cooling system.
    Has the pump tunnel been reiforced?

  5. #5
    Waiting for winter ARCTIC's Avatar
    Join Date
    Jun 2011
    Location
    Iowa
    Posts
    171
    The water gets hot in the engine bay. I forgot to put the plugs in mine and it got some water in it and when I drained it after riding, the water was plenty warm. Put it back in the water with the seats and storage container removed and see if you can tell where it's coming in. If you don't see anything, then start the engine and see if the leak is visible. If you're talking about a LOT of water, leave it on the trailer or lift while inspecting it.

  6. #6
    Waiting for winter ARCTIC's Avatar
    Join Date
    Jun 2011
    Location
    Iowa
    Posts
    171
    Quote Originally Posted by troyheb View Post
    +1 Just because the water was hot does not mean it came from the cooling system.
    Has the pump tunnel been reiforced?
    What does "having the pump tunnel reinforced" mean? Was there a recall?

  7. #7
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    2 of the right sponson bolts leaked on my 08 RXT-X.....unbolt sponson, re-silicone around the thru the hull bolts, re-attach sponson. Done!

    You will need a bright flashlight to see the water triclkling down inside the hull....

  8. #8
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Quote Originally Posted by ARCTIC View Post
    What does "having the pump tunnel reinforced" mean? Was there a recall?
    No recall......see pic.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	070.jpg 
Views:	96 
Size:	128.0 KB 
ID:	246139  

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by ARCTIC View Post
    What does "having the pump tunnel reinforced" mean? Was there a recall?
    Some RXTX's the pump tunnel developes cracks and you need to do a reinforcement like tommygunner.

  10. #10
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    This looks like just an RXT, not the X model...
    So don't worry about pump tunnel til you hit 75 mph..

    I'd check opas hoses first (if you have them), then the Carbon Ring area around driveshaft.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 08 rxt bearing in the motor went how much will this cost ?.?
    By smoked134134 in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-19-2015, 07:08 AM
  2. 2011 RXT-X 260 Taking in water
    By mr.rxtx260 in forum Sea Doo Open Discussion
    Replies: 30
    Last Post: 08-04-2013, 07:42 PM
  3. 08 RXT-X Petrol in Oil? Dead Oil Sensor
    By RXPX in forum 4-Tec Performance
    Replies: 27
    Last Post: 03-04-2012, 12:12 AM
  4. Using a 07 GTX ecu in an 08 RXT X, will it be fine?
    By Otto J in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2011, 08:05 PM
  5. 08 RXT Motor In 05 RXT??????
    By Boostedred in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2011, 09:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •