Results 1 to 7 of 7
  1. #1

    Join Date
    Mar 2010
    Location
    Shorewood, IL
    Posts
    139
    +1
    2

    90 650 runs great for 20 seconds then dies out.

    I put this up in the stroke and this section, not sure where to put it.

    My buddy has a 90 650. We were out riding today and the no wake zone we had to go through take 10-15 minutes to go through. We got through that then we rode around for arounnd 15 minutes and it was still running great. After that it died out. It restarts fine, will run great under half throttle. Anything over half it runs good but then dies about 7-8 seconds after reaching full throttle. Not sure what it could be. We already got new plugs, new fuel filter, made sure the needles on the carb are at the right settings, other than that I'm not sure what to do besides doing a carb rebuild. Anyone else got any suggestions for us to try. This is the first day of an 8 day vacation of riding every day. Thanks for the help in advance.


  2. #2

    Join Date
    Apr 2010
    Location
    Eganville, Ontario, Canada
    Posts
    18
    Check for blockage of the fuel lines. My 98 GP1200 had the exact same symptoms. Turns out it was the fuel switch. Almost zero flow when in the ON position. Switched to RES and it flowed perfect. Problem solved. If not the switch, check the pickup in the tank.

  3. #3

    Join Date
    Mar 2010
    Location
    Shorewood, IL
    Posts
    139
    +1
    2
    Already checked the pick up and bypassed the fuel switch. Seems to be running a liittle bit better on the trailer when we tested it at the launch but it ran fine for 30 min earlier before we had problems.

  4. #4

    Join Date
    Apr 2010
    Location
    Eganville, Ontario, Canada
    Posts
    18
    Could be a problem with pump diaphragm, not flowing enough fuel. If the carbs haven't been rebuilt lately, that might be the answer.

    EDIT: Try pinching off the return lines from the carb while riding. That might help build up enough pressure to feed enough fuel. Are the carbs receiving a good flow of fuel ?

  5. #5

    Join Date
    Mar 2010
    Location
    Shorewood, IL
    Posts
    139
    +1
    2
    The carb seems to be. If it isn't any better today with the fuel switch by passed then I will have him pinch the return line and see how that is. The weird thing is he had it running 2 times already this year and it ran great, we get here and it starts giving him problems, ran great last year.

  6. #6

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    There is a small gas filter in the carb at the fuel pump that might be stopped up.

  7. #7

    Join Date
    Mar 2010
    Location
    Shorewood, IL
    Posts
    139
    +1
    2
    We figured it out. Cracked gas cap.

    Thanks for the help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Virage runs great for 20 min
    By norrislakejunky in forum Polaris Open Discussion
    Replies: 50
    Last Post: 08-30-2013, 07:41 PM
  2. Replies: 6
    Last Post: 05-01-2012, 05:59 PM
  3. 2000 polaris 1200 Runs great for 2 hrs then shuts down?
    By Polaris 1200 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 08-05-2011, 08:24 AM
  4. 90 650 runs great for 20 seconds then dies out.
    By andersonn in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-16-2011, 04:36 PM
  5. why is my polaris slth running fine for a bit then dying out
    By kastay29 in forum Polaris How To & FAQs
    Replies: 26
    Last Post: 06-14-2011, 01:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •