Results 1 to 7 of 7
  1. #1

    Join Date
    Apr 2010
    Location
    Greenville, NC
    Posts
    281
    +1
    4

    Wear Ring Or something else wrong

    So my boss has a 97 sea doo 1800 challenger. So the problem is last time we took it out he had 4 adults 2 kids, 2 coolers full, and a lot of other crap. It would rev-up fine but it was not going anywhere, it would take forever to get up on plane. AND he also took his 98 XP out and they had to tow it back he was running the boat full throttle and was probably only doing 5-10mph. I told him I thought it was either the wear ring or impeller. Now he wants to know what would cause the wear ring to get worn. I told him sucking up crap. Keep in mind we run it in the river and it is not exactly the cleanest place in the world.

    AND when we got where we were going they dropped 2 adults and the 2 kids off and most of the stuff they had on the boat and said it ran fine. I keep telling him I think it is one of those 2 problems and that combined with all that weight just is to much for it.

    Any other thoughts????


  2. #2
    if its not the impeller being worn or a different pitch or bent up it could be the wear ring is worn or its cavitating? Check the ride plate,intake grate and make sure the jet pump is sealing good to the back of the hull.it sounds like cavitation to me or the impeller could b loose on the shaft

  3. #3

    Join Date
    Apr 2010
    Location
    Greenville, NC
    Posts
    281
    +1
    4
    A little late updating this.

    I took a look back there and there was probably an 1/8" gap between the impeller and wear ring. So i replaced both of them. Now the boat anytime you give it full throttle from when it is not on plane it wants to start fouling plugs and not run worth a crap. Thoughts on that?

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by 992door View Post
    A little late updating this.

    I took a look back there and there was probably an 1/8" gap between the impeller and wear ring. So i replaced both of them. Now the boat anytime you give it full throttle from when it is not on plane it wants to start fouling plugs and not run worth a crap. Thoughts on that?
    sounds like you r not getting enough spark. trim back the plug wires and reinstall. see if that helps.

  5. #5
    sounds like it could be bad plugs. trim the boots and try fresh plugs. plugs should be changed almost every season according to sea-doo

  6. #6

    Join Date
    Apr 2010
    Location
    Greenville, NC
    Posts
    281
    +1
    4
    We can put new plugs in it and it will run fine for a little while. But after an hour or 2 when you go to give it full throttle it will still do it. OH one more thing it can be a b**** to started. It just turns over and over and over for about a minute or so before it will crank

  7. #7
    D22jaguar's Avatar
    Join Date
    Sep 2011
    Location
    Saddle Brook, NJ
    Posts
    106
    How`s the fuel filter, see if its got a lot of crap inside. If so replace it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bad cavitation... JB Weld on wear ring or something else?
    By ripcuda in forum Polaris Open Discussion
    Replies: 19
    Last Post: 09-11-2012, 07:13 PM
  2. 07 RXP issue, prop or sc clutch or something else?
    By blandis in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-08-2007, 06:35 AM
  3. Not the wear ring or impellor.
    By RedRyderRXP in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-10-2006, 06:58 PM
  4. SS wear ring or RR mount
    By Flyer in forum 4-Tec Performance
    Replies: 43
    Last Post: 05-23-2006, 08:23 AM
  5. $50.00 wear ring or $250 impeller?
    By Ed in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-06-2005, 03:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •