Results 1 to 9 of 9
  1. #1

    1999 polaris genesis will idle but not rev up.

    I have a 1999 genesis fuel injected ski that sat for about two years. The ski was rebuilt from the crank up and only has about 30 hours on it since that was done. With it setting for two years I know the fuel went bad. I drained all the fuel and replaced with 93 octane. Replaced spark plugs. The ski will idle with no warning lights coming on, but will not rev up. The fuel pressure regulator was at the bottom of the fuel tank, but I fixed it thanks to another post on this web site. I had no warning light with the pressure regulator off either. I have not check the fuel pressure yet but will do so.

    Anyone have any thoughts what it might be.


    Thanks Greg


  2. #2
    WFO 4 LIFE nitrosportman's Avatar
    Join Date
    May 2011
    Location
    Temple, TX
    Posts
    235
    whats your fuel pressure?

  3. #3
    I checked the fuel pressure today and it measures 22psi and around 31psi with the return line to the fuel tank squeezed off. I hope you guys or gals can help me with this. My kids are getting anxious. Greg

  4. #4
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    When you say not rev up, do you mean it does not respond when you hit the gas? Does it try to rev?

  5. #5
    It tries to rev but sounds like its bogging down.

  6. #6
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Probably the TPS. They are known to go bad.

  7. #7
    Any way to check the tps before I purchase one.

  8. #8
    Checked tps and it was unplugged for some reason. Runs great now. Thanks everyone for there help. Greg

  9. #9
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Glad you got it figured out. Have fun on it and be safe.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 polaris virage 700 will start and idle but not run
    By meh2009 in forum Polaris Projects
    Replies: 8
    Last Post: 06-27-2013, 07:16 AM
  2. Will idle but not accelerate
    By bstone81 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-30-2012, 11:21 PM
  3. polaris 780 idles but wont rev up likes its bogging down
    By eam9842 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-21-2011, 09:23 PM
  4. 1999 carb genesis will not start
    By electrician112159 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-05-2009, 09:46 PM
  5. 1999 Polaris SLTH will not start when warm
    By igeoff in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 09-08-2008, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •