Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24

Thread: Why So Slow...

  1. #1
    I finally got ONE!!! ;) RXT-260-DOO's Avatar
    Join Date
    Jun 2011
    Location
    Hot Sulphur Springs, CO
    Posts
    295
    +1
    26

    Unhappy Why So Slow...

    I have this posted in my other post in the open discussion, but figured I wold post here too. Not getting many views there...

    So I now got 12 hours on my new 2011 RXT 260. Had the dealer do the 10 hour service, all is good. Checked oil, it is @ 3/4. Checked all hoses, they are all on good and tight.

    I did a few speed passes last night and here are my max's: 6800 rpm and 56 MPH. Air temp was 74* and water temp was 66*. Before the 10 hour service max I was able to get it to go 60 mph but just barely. Last night was pretty windy and had a slight chop. I am at 8000 feet elevation, so what pitched impeller do I need or should I be seeing better results than this without a different impeller?

    Thanks Guys!!!
    Jeremy


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    You just need to repitch what you have or pick up a depitched 15/20

  3. #3
    I finally got ONE!!! ;) RXT-260-DOO's Avatar
    Join Date
    Jun 2011
    Location
    Hot Sulphur Springs, CO
    Posts
    295
    +1
    26
    Thanks Ocman. I will read through the re-pitching thread.

  4. #4
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    No prob bro.

  5. #5
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    I would take the impeller out and send it to Erik at www.speedfreeksracing.com with all of your detailed information. He is a professional at this and will have you going full tilt!

  6. #6
    I finally got ONE!!! ;) RXT-260-DOO's Avatar
    Join Date
    Jun 2011
    Location
    Hot Sulphur Springs, CO
    Posts
    295
    +1
    26
    Been searching and have yet to find a 2011 service manual? Any one know where I can get one or just go through my local dealer?

  7. #7
    I finally got ONE!!! ;) RXT-260-DOO's Avatar
    Join Date
    Jun 2011
    Location
    Hot Sulphur Springs, CO
    Posts
    295
    +1
    26
    Quote Originally Posted by jpt7779 View Post
    I would take the impeller out and send it to Erik at www.speedfreeksracing.com with all of your detailed information. He is a professional at this and will have you going full tilt!
    Was thinking the same exact thing, just need a service manual for pulling it... Was about to send an e-mail but figured I better get the impeller out first...

  8. #8

    Join Date
    Jun 2009
    Location
    grand cayman
    Posts
    124
    That isnt a prop problem something else is wrong! check supercharger slip, oil filter, there has to be something wrong with the ski

  9. #9

    Join Date
    Jul 2010
    Location
    Daytona Beach
    Posts
    406
    60 mph on a 260? is that GPS or speedo? and the speeds are dropping? sounds like more than just a prop pitch problem. those speeds are low for a 215.

  10. #10
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by GPRXP4ME View Post
    That isnt a prop problem something else is wrong! check supercharger slip, oil filter, there has to be something wrong with the ski
    He is at 8000 feet and that is a major power robber but I would definitley be checking for boost leaks before messing with the prop. 6800 rpms is obviously way low. Pitching a prop to make up for 1300rpms seams rediculous to me. Would be better off starting with a 215 prop.
    If my caluclations are correct the elevation alone will kill more than 20% of his power so he's not far off from that.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why is my VXR so slow?
    By JonDaddy82 in forum Yamaha PWC Performance (4-stroke)
    Replies: 45
    Last Post: 08-14-2013, 08:39 PM
  2. 67.5 Why so slow???
    By Jrod0813 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 14
    Last Post: 08-31-2008, 09:29 AM
  3. Why is this GTX SC so slow?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-24-2007, 08:41 PM
  4. Why are the 06 RXP's so slow?
    By JD 1 in forum 4-Tec Performance
    Replies: 129
    Last Post: 10-15-2006, 09:57 AM
  5. Help! Why am I so slow?
    By GPR FL in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-05-2006, 07:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •